Upstream information

CVE-2018-1000637 at MITRE

Description

zutils version prior to version 1.8-pre2 contains a Buffer Overflow vulnerability in zcat that can result in Potential denial of service or arbitrary code execution. This attack appear to be exploitable via the victim openning a crafted compressed file. This vulnerability appears to have been fixed in 1.8-pre2.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1103878 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • zutils >= 1.7-lp150.2.3.1
  • zutils-debuginfo >= 1.7-lp150.2.3.1
  • zutils-debugsource >= 1.7-lp150.2.3.1
Patchnames:
openSUSE-2018-951
openSUSE Leap 42.3
  • zutils >= 1.7-4.3.1
  • zutils-debuginfo >= 1.7-4.3.1
  • zutils-debugsource >= 1.7-4.3.1
Patchnames:
openSUSE-2018-951