Upstream information

CVE-2018-1000021 at MITRE

Description

GIT version 2.15.1 and earlier contains a Input Validation Error vulnerability in Client that can result in problems including messing up terminal configuration to RCE. This attack appear to be exploitable via The user must interact with a malicious git server, (or have their traffic modified in a MITM attack).

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 6.8
Vector AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact None
SUSE Bugzilla entry: 1079389 [RESOLVED / WONTFIX]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 git Ignore
OpenStack Cloud Magnum Orchestration 7.0 git Ignore
SUSE Linux Enterprise SDK 11 SP4 git Ignore
SUSE Linux Enterprise SDK 12 SP2 git Ignore
SUSE Linux Enterprise SDK 12 SP3 git Ignore
SUSE Linux Enterprise Server 12 GA LTSS git Ignore
SUSE Linux Enterprise Server 12 SP1 LTSS git Ignore
SUSE Linux Enterprise Server 12 SP2 git Ignore
SUSE Linux Enterprise Server 12 SP3 git Ignore
SUSE Studio Onsite 1.3 git Ignore