Upstream information

CVE-2017-7529 at MITRE

Description

Nginx versions since 0.5.6 up to and including 1.13.2 are vulnerable to integer overflow vulnerability in nginx range filter module resulting into leak of potentially sensitive information triggered by specially crafted request.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 1048265 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Lifecycle Management Server 1.3
  • nginx-1.0 >= 1.0.15-0.35.3.1
Patchnames:
sleslms13-nginx-1.0-13271
SUSE Studio Onsite 1.3
  • nginx-1.0 >= 1.0.15-0.35.3.1
Patchnames:
slestso13-nginx-1.0-13271
SUSE WebYast 1.3
  • nginx-1.0 >= 1.0.15-0.35.3.1
Patchnames:
slewyst13-nginx-1.0-13271
openSUSE Leap 42.2
  • nginx >= 1.8.1-10.5.1
  • nginx-debuginfo >= 1.8.1-10.5.1
  • nginx-debugsource >= 1.8.1-10.5.1
Patchnames:
openSUSE-2017-867


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Lifecycle Management Server 1.3 nginx-1.0 Released
SUSE Studio Onsite 1.3 nginx-1.0 Released
WebYaST 1.3 nginx-1.0 Released