Upstream information

CVE-2017-7529 at MITRE

Description

Nginx versions since 0.5.6 up to and including 1.13.2 are vulnerable to integer overflow vulnerability in nginx range filter module resulting into leak of potentially sensitive information triggered by specially crafted request.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1048265 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Lifecycle Management Server 1.3
  • nginx-1.0 >= 1.0.15-0.35.3.1
Patchnames:
sleslms13-nginx-1.0-13271
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • nginx >= 1.14.0-4.24
  • nginx-source >= 1.14.0-4.24
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • nginx >= 1.16.1-1.21
  • nginx-source >= 1.16.1-1.21
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • nginx >= 1.19.8-1.1
  • nginx-source >= 1.19.8-1.1
SUSE Linux Enterprise Module for Server Applications 15
  • nginx >= 1.14.0-1.14
SUSE Package Hub for SUSE Linux Enterprise 12
  • nginx >= 1.13.9-12.1
  • vim-plugin-nginx >= 1.13.9-12.1
Patchnames:
openSUSE-2018-310
SUSE Studio Onsite 1.3
  • nginx-1.0 >= 1.0.15-0.35.3.1
Patchnames:
slestso13-nginx-1.0-13271
SUSE WebYast 1.3
  • nginx-1.0 >= 1.0.15-0.35.3.1
Patchnames:
slewyst13-nginx-1.0-13271
openSUSE Tumbleweed
  • nginx >= 1.21.3-1.4
  • nginx-source >= 1.21.3-1.4
  • ruby2.7-rubygem-passenger >= 6.0.8-3.2
  • ruby3.0-rubygem-passenger >= 6.0.8-3.2
  • rubygem-passenger >= 6.0.8-3.2
  • rubygem-passenger-apache2 >= 6.0.8-3.2
  • rubygem-passenger-nginx >= 6.0.8-3.2
  • vim-plugin-nginx >= 1.21.3-1.4
Patchnames:
openSUSE Tumbleweed GA nginx-1.21.3-1.4
openSUSE Tumbleweed GA ruby2.7-rubygem-passenger-6.0.8-3.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications nginx-1.0 Released
SUSE Lifecycle Management Server 1.3 nginx-1.0 Released
SUSE Linux Enterprise High Performance Computing 15 LTSS nginx Already fixed
SUSE Linux Enterprise Server 15 LTSS nginx Already fixed
SUSE Linux Enterprise Server ESPOS 15 nginx Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 nginx Already fixed
SUSE Studio Onsite nginx-1.0 Released
WebYaST for SLE-11 nginx-1.0 Released