Upstream information

CVE-2017-6503 at MITRE

Description

WebUI in qBittorrent before 3.3.11 did not escape many values, which could potentially lead to XSS.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.30
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.1
Vector AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Changed
Confidentiality Impact Low
Integrity Impact Low
Availability Impact None
SUSE Bugzilla entry: 1028072 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.1
  • qbittorrent >= 3.3.11-6.1
  • qbittorrent-debuginfo >= 3.3.11-6.1
  • qbittorrent-debugsource >= 3.3.11-6.1
  • qbittorrent-nox >= 3.3.11-6.1
  • qbittorrent-nox-debuginfo >= 3.3.11-6.1
Patchnames:
openSUSE-2017-381
openSUSE Leap 42.2
  • qbittorrent >= 3.3.11-2.3.1
  • qbittorrent-debuginfo >= 3.3.11-2.3.1
  • qbittorrent-debugsource >= 3.3.11-2.3.1
  • qbittorrent-nox >= 3.3.11-2.3.1
  • qbittorrent-nox-debuginfo >= 3.3.11-2.3.1
Patchnames:
openSUSE-2017-381