Upstream information

CVE-2017-18191 at MITRE

Description

An issue was discovered in OpenStack Nova 15.x through 15.1.0 and 16.x through 16.1.1. By detaching and reattaching an encrypted volume, an attacker may access the underlying raw volume and corrupt the LUKS header, resulting in a denial of service attack on the compute host. (The same code error also results in data loss, but that is not a vulnerability because the user loses their own data.) All Nova setups supporting encrypted volumes are affected.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:N/AC:L/Au:N/C:N/I:N/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
CVSS v3 Scores
  SUSE
Base Score 7.3
Vector AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Changed
Confidentiality Impact None
Integrity Impact Low
Availability Impact High
SUSE Bugzilla entry: 1081685 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE OpenStack Cloud 7
  • openstack-nova >= 14.0.11~dev13-4.22.1
  • openstack-nova-api >= 14.0.11~dev13-4.22.1
  • openstack-nova-cells >= 14.0.11~dev13-4.22.1
  • openstack-nova-cert >= 14.0.11~dev13-4.22.1
  • openstack-nova-compute >= 14.0.11~dev13-4.22.1
  • openstack-nova-conductor >= 14.0.11~dev13-4.22.1
  • openstack-nova-console >= 14.0.11~dev13-4.22.1
  • openstack-nova-consoleauth >= 14.0.11~dev13-4.22.1
  • openstack-nova-doc >= 14.0.11~dev13-4.22.1
  • openstack-nova-novncproxy >= 14.0.11~dev13-4.22.1
  • openstack-nova-placement-api >= 14.0.11~dev13-4.22.1
  • openstack-nova-scheduler >= 14.0.11~dev13-4.22.1
  • openstack-nova-serialproxy >= 14.0.11~dev13-4.22.1
  • openstack-nova-vncproxy >= 14.0.11~dev13-4.22.1
  • python-nova >= 14.0.11~dev13-4.22.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-988


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Openstack Cloud 6 openstack-nova Ignore
SUSE Openstack Cloud 7 openstack-nova Released