Upstream information

CVE-2017-17760 at MITRE

Description

OpenCV 3.3.1 has a Buffer Overflow in the cv::PxMDecoder::readData function in grfmt_pxm.cpp, because an incorrect size value is used.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 1074313 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.3
  • libopencv-qt56_3 >= 3.1.0-4.11.1
  • libopencv-qt56_3-debuginfo >= 3.1.0-4.11.1
  • libopencv3_1 >= 3.1.0-4.11.1
  • libopencv3_1-debuginfo >= 3.1.0-4.11.1
  • opencv >= 3.1.0-4.11.1
  • opencv-debuginfo >= 3.1.0-4.11.1
  • opencv-debugsource >= 3.1.0-4.11.1
  • opencv-devel >= 3.1.0-4.11.1
  • opencv-doc >= 3.1.0-4.11.1
  • opencv-qt5 >= 3.1.0-4.11.1
  • opencv-qt5-debuginfo >= 3.1.0-4.11.1
  • opencv-qt5-debugsource >= 3.1.0-4.11.1
  • opencv-qt5-devel >= 3.1.0-4.11.1
  • opencv-qt5-doc >= 3.1.0-4.11.1
  • python-opencv >= 3.1.0-4.11.1
  • python-opencv-debuginfo >= 3.1.0-4.11.1
  • python-opencv-qt5 >= 3.1.0-4.11.1
  • python-opencv-qt5-debuginfo >= 3.1.0-4.11.1
  • python3-opencv >= 3.1.0-4.11.1
  • python3-opencv-debuginfo >= 3.1.0-4.11.1
  • python3-opencv-qt5 >= 3.1.0-4.11.1
  • python3-opencv-qt5-debuginfo >= 3.1.0-4.11.1
Patchnames:
openSUSE-2018-534