Upstream information

CVE-2016-4456 at MITRE

Description

The "GNUTLS_KEYLOGFILE" environment variable in gnutls 3.4.12 allows remote attackers to overwrite and corrupt arbitrary files in the filesystem.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 4.9
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N AV:L/AC:L/Au:N/C:N/I:C/A:N
Access Vector Network Local
Access Complexity Low Low
Authentication None None
Confidentiality Impact None None
Integrity Impact Partial Complete
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact High
Availability Impact None

Note from the SUSE Security Team

This problem only affected the gnutls 3.4.12 release, no other releases were affected. So no SUSE Linux Enterprise or openSUSE product is affected by this problem.

SUSE Bugzilla entry: 983471 [RESOLVED / UPSTREAM]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 GA gnutls Not affected
SUSE Linux Enterprise Desktop 12 SP1 gnutls Unsupported
SUSE Linux Enterprise High Availability Extension 11 SP4 gnutls Not affected
SUSE Linux Enterprise SDK 11 SP4 gnutls Not affected
SUSE Linux Enterprise SDK 12 GA gnutls Not affected
SUSE Linux Enterprise SDK 12 SP1 gnutls Unsupported
SUSE Linux Enterprise Server 10 SP4 LTSS gnutls Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS gnutls Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS gnutls Not affected
SUSE Linux Enterprise Server 11 SP4 gnutls Not affected
SUSE Linux Enterprise Server 12 GA gnutls Not affected
SUSE Linux Enterprise Server 12 SP1 gnutls Unsupported