Upstream information

CVE-2016-1016 at MITRE

Description

Use-after-free vulnerability in the Transform object implementation in Adobe Flash Player before 18.0.0.343 and 19.x through 21.x before 21.0.0.213 on Windows and OS X and before 11.2.202.616 on Linux allows attackers to execute arbitrary code via a flash.geom.Matrix callback, a different vulnerability than CVE-2016-1011, CVE-2016-1013, CVE-2016-1017, and CVE-2016-1031.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.33
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High

This issue is currently rated as having moderate severity.

SUSE Bugzilla entries: 1021364 [IN_PROGRESS], 1021616 [CONFIRMED], 974209 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • flash-player >= 11.2.202.621-130.1
  • flash-player-gnome >= 11.2.202.621-130.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-772
SUSE Linux Enterprise Desktop 12 SP1
  • flash-player >= 11.2.202.621-130.1
  • flash-player-gnome >= 11.2.202.621-130.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-772
SUSE Linux Enterprise Workstation Extension 12
  • flash-player >= 11.2.202.621-130.1
  • flash-player-gnome >= 11.2.202.621-130.1
Patchnames:
SUSE-SLE-WE-12-2016-772
SUSE Linux Enterprise Workstation Extension 12 SP1
  • flash-player >= 11.2.202.621-130.1
  • flash-player-gnome >= 11.2.202.621-130.1
Patchnames:
SUSE-SLE-WE-12-SP1-2016-772
openSUSE 13.2 NonFree
  • flash-player >= 11.2.202.621-2.97.1
  • flash-player-gnome >= 11.2.202.621-2.97.1
  • flash-player-kde4 >= 11.2.202.621-2.97.1
Patchnames:
openSUSE-2016-585


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Desktop 12 SP2
  • SUSE Linux Enterprise SDK 11 SP4
  • SUSE Linux Enterprise SDK 12 SP2
  • SUSE Linux Enterprise Server 12 SP2
  • SUSE Linux Enterprise Server for SAP 12 GA
  • SUSE Linux Enterprise Server for SAP 12 SP1
  • SUSE Linux Enterprise Server for SAP 12 SP2
lcms2