Upstream information

CVE-2015-7097 at MITRE

Description

WebKit in Apple iOS before 9.2, Safari before 9.0.2, and tvOS before 9.1 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than CVE-2015-7048, CVE-2015-7095, CVE-2015-7096, CVE-2015-7098, CVE-2015-7099, CVE-2015-7100, CVE-2015-7101, CVE-2015-7102, and CVE-2015-7103.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 1082221 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.1
  • libjavascriptcoregtk-4_0-18 >= 2.10.7-7.1
  • libjavascriptcoregtk-4_0-18-32bit >= 2.10.7-7.1
  • libjavascriptcoregtk-4_0-18-debuginfo >= 2.10.7-7.1
  • libjavascriptcoregtk-4_0-18-debuginfo-32bit >= 2.10.7-7.1
  • libwebkit2gtk-4_0-37 >= 2.10.7-7.1
  • libwebkit2gtk-4_0-37-32bit >= 2.10.7-7.1
  • libwebkit2gtk-4_0-37-debuginfo >= 2.10.7-7.1
  • libwebkit2gtk-4_0-37-debuginfo-32bit >= 2.10.7-7.1
  • libwebkit2gtk3-lang >= 2.10.7-7.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.10.7-7.1
  • typelib-1_0-WebKit2-4_0 >= 2.10.7-7.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.10.7-7.1
  • webkit-jsc-4 >= 2.10.7-7.1
  • webkit-jsc-4-debuginfo >= 2.10.7-7.1
  • webkit2gtk-4_0-injected-bundles >= 2.10.7-7.1
  • webkit2gtk-4_0-injected-bundles-debuginfo >= 2.10.7-7.1
  • webkit2gtk3 >= 2.10.7-7.1
  • webkit2gtk3-debugsource >= 2.10.7-7.1
  • webkit2gtk3-devel >= 2.10.7-7.1
Patchnames:
openSUSE-2016-340