Upstream information

CVE-2015-3751 at MITRE

Description

WebKit in Apple Safari before 6.2.8, 7.x before 7.1.8, and 8.x before 8.0.8, as used in iOS before 8.4.1 and other products, allows remote attackers to bypass a Content Security Policy protection mechanism by using a video control in conjunction with an IMG element within an OBJECT element.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 1082221 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.1
  • libjavascriptcoregtk-4_0-18 >= 2.10.7-7.1
  • libjavascriptcoregtk-4_0-18-32bit >= 2.10.7-7.1
  • libjavascriptcoregtk-4_0-18-debuginfo >= 2.10.7-7.1
  • libjavascriptcoregtk-4_0-18-debuginfo-32bit >= 2.10.7-7.1
  • libwebkit2gtk-4_0-37 >= 2.10.7-7.1
  • libwebkit2gtk-4_0-37-32bit >= 2.10.7-7.1
  • libwebkit2gtk-4_0-37-debuginfo >= 2.10.7-7.1
  • libwebkit2gtk-4_0-37-debuginfo-32bit >= 2.10.7-7.1
  • libwebkit2gtk3-lang >= 2.10.7-7.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.10.7-7.1
  • typelib-1_0-WebKit2-4_0 >= 2.10.7-7.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.10.7-7.1
  • webkit-jsc-4 >= 2.10.7-7.1
  • webkit-jsc-4-debuginfo >= 2.10.7-7.1
  • webkit2gtk-4_0-injected-bundles >= 2.10.7-7.1
  • webkit2gtk-4_0-injected-bundles-debuginfo >= 2.10.7-7.1
  • webkit2gtk3 >= 2.10.7-7.1
  • webkit2gtk3-debugsource >= 2.10.7-7.1
  • webkit2gtk3-devel >= 2.10.7-7.1
Patchnames:
openSUSE-2016-340