Upstream information

CVE-2015-1856 at MITRE

Description

OpenStack Object Storage (Swift) before 2.3.0, when allow_version is configured, allows remote authenticated users to delete the latest version of an object by leveraging listing access to the x-versions-location container.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.5
Vector AV:N/AC:L/Au:S/C:N/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 927793 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE OpenStack Cloud 5
  • openstack-swift >= 2.1.0-11.1
  • openstack-swift-account >= 2.1.0-11.1
  • openstack-swift-container >= 2.1.0-11.1
  • openstack-swift-doc >= 2.1.0-11.1
  • openstack-swift-object >= 2.1.0-11.1
  • openstack-swift-proxy >= 2.1.0-11.1
  • python-swift >= 2.1.0-11.1
Patchnames:
sleclo50sp3-openstack-swift-12171
SUSE OpenStack Cloud 6
  • openstack-swift >= 2.1.0-4.1
  • openstack-swift-account >= 2.1.0-4.1
  • openstack-swift-container >= 2.1.0-4.1
  • openstack-swift-object >= 2.1.0-4.1
  • openstack-swift-proxy >= 2.1.0-4.1
  • python-swift >= 2.1.0-4.1
Patchnames:
SUSE OpenStack Cloud 6 GA openstack-swift


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Cloud 11.3 openstack-swift Already fixed
SUSE Cloud 2.0 openstack-swift Already fixed
SUSE Cloud 3 openstack-swift Ignore
SUSE Cloud 4 openstack-swift Ignore
SUSE Cloud 5 openstack-swift Released