Upstream information

CVE-2013-4560 at MITRE

Description

Use-after-free vulnerability in lighttpd before 1.4.33 allows remote attackers to cause a denial of service (segmentation fault and crash) via unspecified vectors that trigger FAMMonitorDirectory failures.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 850469 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability 12 SP2
  • lighttpd >= 1.4.35-1.34
SUSE Linux Enterprise High Availability 12 SP3
SUSE Linux Enterprise High Availability 12 SP4
SUSE Linux Enterprise High Availability 12 SP5
  • lighttpd >= 1.4.35-3.1
SUSE Linux Enterprise High Availability Extension 11 SP2
  • lighttpd >= 1.4.20-2.52.1
Patchnames:
sleshasp2-lighttpd
SUSE Linux Enterprise High Availability Extension 11 SP3
  • lighttpd >= 1.4.20-2.52.1
Patchnames:
slehasp3-lighttpd
SUSE Linux Enterprise Software Development Kit 11 SP2
  • lighttpd >= 1.4.20-2.52.1
  • lighttpd-mod_cml >= 1.4.20-2.52.1
  • lighttpd-mod_magnet >= 1.4.20-2.52.1
  • lighttpd-mod_mysql_vhost >= 1.4.20-2.52.1
  • lighttpd-mod_rrdtool >= 1.4.20-2.52.1
  • lighttpd-mod_trigger_b4_dl >= 1.4.20-2.52.1
  • lighttpd-mod_webdav >= 1.4.20-2.52.1
Patchnames:
sdksp2-lighttpd
SUSE Linux Enterprise Software Development Kit 11 SP3
  • lighttpd >= 1.4.20-2.52.1
  • lighttpd-mod_cml >= 1.4.20-2.52.1
  • lighttpd-mod_magnet >= 1.4.20-2.52.1
  • lighttpd-mod_mysql_vhost >= 1.4.20-2.52.1
  • lighttpd-mod_rrdtool >= 1.4.20-2.52.1
  • lighttpd-mod_trigger_b4_dl >= 1.4.20-2.52.1
  • lighttpd-mod_webdav >= 1.4.20-2.52.1
Patchnames:
sdksp3-lighttpd
openSUSE Tumbleweed
  • lighttpd >= 1.4.37-1.6
  • lighttpd-mod_cml >= 1.4.37-1.6
  • lighttpd-mod_geoip >= 1.4.37-1.6
  • lighttpd-mod_magnet >= 1.4.37-1.6
  • lighttpd-mod_mysql_vhost >= 1.4.37-1.6
  • lighttpd-mod_rrdtool >= 1.4.37-1.6
  • lighttpd-mod_trigger_b4_dl >= 1.4.37-1.6
  • lighttpd-mod_webdav >= 1.4.37-1.6
Patchnames:
openSUSE Tumbleweed GA lighttpd-1.4.37-1.6


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability Extension 11 SP2 lighttpd Released
SUSE Linux Enterprise High Availability Extension 11 SP3 lighttpd Released
SUSE Linux Enterprise High Availability Extension 12 SP3 lighttpd Already fixed
SUSE Linux Enterprise High Availability Extension 12 SP4 lighttpd Already fixed
SUSE Linux Enterprise High Availability Extension 12 SP5 lighttpd Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 lighttpd Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 lighttpd Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 lighttpd Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP2 lighttpd Released
SUSE Linux Enterprise Software Development Kit 11 SP3 lighttpd Released