Upstream information

CVE-2013-2038 at MITRE

Description

The NMEA0183 driver in gpsd before 3.9 allows remote attackers to cause a denial of service (daemon termination) and possibly execute arbitrary code via a GPS packet with a malformed $GPGGA interpreted sentence that lacks certain fields and a terminator. NOTE: a separate issue in the AIS driver was also reported, but it might not be a vulnerability.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 8.5
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:L/Au:N/C:C/I:N/A:P
Access Vector Network Network
Access Complexity Medium Low
Authentication None None
Confidentiality Impact None Complete
Integrity Impact None None
Availability Impact Partial Partial
SUSE Bugzilla entry: 818136 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 13.1
  • gpsd >= 3.5-7.8.1
  • gpsd-clients >= 3.5-7.8.1
  • gpsd-clients-debuginfo >= 3.5-7.8.1
  • gpsd-debuginfo >= 3.5-7.8.1
  • gpsd-debugsource >= 3.5-7.8.1
  • gpsd-devel >= 3.5-7.8.1
  • gpsd-devel-debuginfo >= 3.5-7.8.1
  • libQgpsmm20 >= 3.5-7.8.1
  • libQgpsmm20-debuginfo >= 3.5-7.8.1
  • libgps20 >= 3.5-7.8.1
  • libgps20-debuginfo >= 3.5-7.8.1
  • python-gpsd >= 3.5-7.8.1
  • python-gpsd-debuginfo >= 3.5-7.8.1
Patchnames:
openSUSE-2015-531


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP3 gpsd Ignore