Upstream information

CVE-2011-4128 at MITRE

Description

Buffer overflow in the gnutls_session_get_data function in lib/gnutls_session.c in GnuTLS 2.12.x before 2.12.14 and 3.x before 3.0.7, when used on a client that performs nonstandard session resumption, allows remote TLS servers to cause a denial of service (application crash) via a large SessionTicket.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 729486 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
  • gnutls >= 3.2.15-11.1
  • libgnutls28 >= 3.2.15-11.1
  • libgnutls28-32bit >= 3.2.15-11.1
SUSE Linux Enterprise Desktop 12 SP3
  • gnutls >= 3.3.27-1.10
  • libgnutls28 >= 3.3.27-1.10
  • libgnutls28-32bit >= 3.3.27-1.10
SUSE Linux Enterprise Desktop 12 SP4
  • gnutls >= 3.3.27-3.3.1
  • libgnutls28 >= 3.3.27-3.3.1
  • libgnutls28-32bit >= 3.3.27-3.3.1
SUSE Linux Enterprise Desktop 12
  • gnutls >= 3.2.15-1.8
  • libgnutls28 >= 3.2.15-1.8
  • libgnutls28-32bit >= 3.2.15-1.8
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • gnutls >= 3.3.27-3.3.1
  • libgnutls-openssl27 >= 3.3.27-3.3.1
  • libgnutls28 >= 3.3.27-3.3.1
  • libgnutls28-32bit >= 3.3.27-3.3.1
SUSE Linux Enterprise Module for Basesystem 15
  • gnutls >= 3.6.2-4.15
  • libgnutls-devel >= 3.6.2-4.15
  • libgnutls30 >= 3.6.2-4.15
  • libgnutlsxx-devel >= 3.6.2-4.15
  • libgnutlsxx28 >= 3.6.2-4.15
SUSE Linux Enterprise Module for Desktop Applications 15
  • libgnutls30-32bit >= 3.6.2-4.15
SUSE Linux Enterprise Server 11 SP1
  • gnutls >= 2.4.1-24.39.33.1
  • libgnutls-extra26 >= 2.4.1-24.39.53.1
  • libgnutls26 >= 2.4.1-24.39.33.1
  • libgnutls26-32bit >= 2.4.1-24.39.53.1
  • libgnutls26-x86 >= 2.4.1-24.39.39.1
Patchnames:
slessp1-gnutls
SUSE Linux Enterprise Server 11 SP2
  • gnutls >= 2.4.1-24.39.33.1
  • libgnutls26 >= 2.4.1-24.39.33.1
  • libgnutls26-32bit >= 2.4.1-24.39.33.1
  • libgnutls26-x86 >= 2.4.1-24.39.33.1
SUSE Linux Enterprise Server 11 SP3
  • gnutls >= 2.4.1-24.39.45.1
  • libgnutls-extra26 >= 2.4.1-24.39.45.1
  • libgnutls26 >= 2.4.1-24.39.45.1
  • libgnutls26-32bit >= 2.4.1-24.39.45.1
  • libgnutls26-x86 >= 2.4.1-24.39.45.1
SUSE Linux Enterprise Server 11 SP4
  • gnutls >= 2.4.1-24.39.55.1
  • libgnutls-extra26 >= 2.4.1-24.39.55.1
  • libgnutls26 >= 2.4.1-24.39.55.1
  • libgnutls26-32bit >= 2.4.1-24.39.55.1
  • libgnutls26-x86 >= 2.4.1-24.39.55.1
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12 SP2
  • gnutls >= 3.2.15-11.1
  • libgnutls-openssl27 >= 3.2.15-11.1
  • libgnutls28 >= 3.2.15-11.1
  • libgnutls28-32bit >= 3.2.15-11.1
SUSE Linux Enterprise Server 12 SP3
  • gnutls >= 3.3.27-1.10
  • libgnutls-openssl27 >= 3.3.27-1.10
  • libgnutls28 >= 3.3.27-1.10
  • libgnutls28-32bit >= 3.3.27-1.10
SUSE Linux Enterprise Server 12
  • gnutls >= 3.2.15-1.8
  • libgnutls-openssl27 >= 3.2.15-1.8
  • libgnutls28 >= 3.2.15-1.8
  • libgnutls28-32bit >= 3.2.15-1.8
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gnutls >= 3.2.15-11.1
  • libgnutls-openssl27 >= 3.2.15-11.1
  • libgnutls28 >= 3.2.15-11.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libgnutls-devel >= 2.4.1-24.39.55.1
  • libgnutls-extra-devel >= 2.4.1-24.39.55.1
  • libgnutls-extra26 >= 2.4.1-24.39.55.1
SUSE Linux Enterprise Software Development Kit 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libgnutls-devel >= 3.2.15-11.1
  • libgnutls-openssl-devel >= 3.2.15-11.1
  • libgnutlsxx-devel >= 3.2.15-11.1
  • libgnutlsxx28 >= 3.2.15-11.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libgnutls-devel >= 3.3.27-1.10
  • libgnutls-openssl-devel >= 3.3.27-1.10
  • libgnutlsxx-devel >= 3.3.27-1.10
  • libgnutlsxx28 >= 3.3.27-1.10
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libgnutls-devel >= 3.3.27-3.3.1
  • libgnutls-openssl-devel >= 3.3.27-3.3.1
  • libgnutlsxx-devel >= 3.3.27-3.3.1
  • libgnutlsxx28 >= 3.3.27-3.3.1
SUSE Linux Enterprise Software Development Kit 12
  • libgnutls-devel >= 3.2.15-1.8
  • libgnutls-openssl-devel >= 3.2.15-1.8
  • libgnutlsxx-devel >= 3.2.15-1.8
  • libgnutlsxx28 >= 3.2.15-1.8
openSUSE Leap 15.0
  • gnutls >= 3.6.2-lp150.3.2
  • libgnutls-dane0 >= 3.6.2-lp150.3.2
  • libgnutls30 >= 3.6.2-lp150.3.2
Patchnames:
openSUSE Leap 15.0 GA gnutls-3.6.2-lp150.3.2
openSUSE Tumbleweed
  • gnutls >= 3.4.15-1.1
  • gnutls-guile >= 3.4.15-1.1
  • libgnutls-dane-devel >= 3.4.15-1.1
  • libgnutls-dane0 >= 3.4.15-1.1
  • libgnutls-devel >= 3.4.15-1.1
  • libgnutls-devel-32bit >= 3.4.15-1.1
  • libgnutls-openssl-devel >= 3.4.15-1.1
  • libgnutls-openssl27 >= 3.4.15-1.1
  • libgnutls30 >= 3.4.15-1.1
  • libgnutls30-32bit >= 3.4.15-1.1
  • libgnutlsxx-devel >= 3.4.15-1.1
  • libgnutlsxx28 >= 3.4.15-1.1
Patchnames:
openSUSE Tumbleweed GA gnutls-3.4.15-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 gnutls Affected
SUSE Linux Enterprise High Availability Extension 11 SP1 gnutls Affected
SUSE Linux Enterprise Server 11 SP1 gnutls Affected
SUSE Linux Enterprise Server 11 SP1 LTSS gnutls Affected
SUSE Linux Enterprise Server for SAP Business All-in-One gnutls Affected
SUSE Linux Enterprise Software Development Kit 11 SP1 gnutls Affected