Upstream information

CVE-2011-2766 at MITRE

Description

The FCGI (aka Fast CGI) module 0.70 through 0.73 for Perl, as used by CGI::Fast, uses environment variable values from one request during processing of a later request, which allows remote attackers to bypass authentication via crafted HTTP headers.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 735882 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • perl-CGI >= 4.38-1.17
SUSE Linux Enterprise Module for Development Tools 15
SUSE Linux Enterprise Module for Development Tools 15 SP1
SUSE Linux Enterprise Module for Development Tools 15 SP2
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • FastCGI >= 2.4.0-2.23
  • FastCGI-devel >= 2.4.0-2.23
  • libfcgi0 >= 2.4.0-2.23
  • perl-FastCGI >= 2.4.0-2.23
SUSE Linux Enterprise Software Development Kit 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • FastCGI >= 2.4.0-168.1
  • FastCGI-devel >= 2.4.0-168.1
  • perl-FastCGI >= 2.4.0-168.1
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • FastCGI >= 2.4.0-167.1
  • perl-FastCGI >= 2.4.0-167.1
openSUSE Tumbleweed
  • FastCGI >= 2.4.0-171.10
  • FastCGI-devel >= 2.4.0-171.10
  • libfcgi0 >= 2.4.0-171.10
  • perl-CGI >= 4.35-1.1
  • perl-FastCGI >= 2.4.0-171.10
Patchnames:
openSUSE Tumbleweed GA FastCGI-2.4.0-171.10