Upstream information

CVE-2011-2524 at MITRE

Description

Directory traversal vulnerability in soup-uri.c in SoupServer in libsoup before 2.35.4 allows remote attackers to read arbitrary files via a %2e%2e (encoded dot dot) in a URI.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 706630 [RESOLVED / FIXED], 709167 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • libsoup-2_4-1 >= 2.28.2-0.3.1
  • libsoup-2_4-1-32bit >= 2.28.2-0.3.1
  • libsoup-2_4-1-x86 >= 2.28.2-0.3.1
Patchnames:
slessp1-libsoup
SUSE Linux Enterprise Server 11 SP2
  • libsoup-2_4-1 >= 2.32.2-4.7.1
  • libsoup-2_4-1-32bit >= 2.32.2-4.7.1
  • libsoup-2_4-1-x86 >= 2.32.2-4.7.1
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP4
  • libsoup-2_4-1 >= 2.32.2-4.13.1
  • libsoup-2_4-1-32bit >= 2.32.2-4.13.1
  • libsoup-2_4-1-x86 >= 2.32.2-4.13.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libsoup-devel >= 2.32.2-4.13.1
  • libsoup-devel-32bit >= 2.32.2-4.13.1
openSUSE 11.3
  • libsoup-2_4-1-debuginfo >= 2.30.1-2.3.1
  • libsoup-2_4-1-debuginfo-32bit >= 2.30.1-2.3.1
openSUSE 11.3
  • libsoup-2_4-1 >= 2.30.1-2.3.1
  • libsoup-2_4-1-32bit >= 2.30.1-2.3.1
openSUSE 11.4
  • libsoup-2_4-1 >= 2.32.2-3.4.1
  • libsoup-2_4-1-32bit >= 2.32.2-3.4.1
SUSE Linux Enterprise Software Development Kit 11 SP1
  • libsoup-devel >= 2.28.2-0.3.1
Builds
SAT Patch Nr: 4945
SUSE Linux Enterprise Software Development Kit 11 SP1
  • libsoup-devel >= 2.28.2-0.3.1
  • libsoup-devel-32bit >= 2.28.2-0.3.1
Builds
SAT Patch Nr: 4945
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • libsoup-2_4-1 >= 2.28.2-0.3.1
Builds
SAT Patch Nr: 4945
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • libsoup-2_4-1 >= 2.28.2-0.3.1
  • libsoup-2_4-1-32bit >= 2.28.2-0.3.1
Builds
SAT Patch Nr: 4945
SUSE Linux Enterprise Server 11 SP1
  • libsoup-2_4-1 >= 2.28.2-0.3.1
  • libsoup-2_4-1-x86 >= 2.28.2-0.3.1
Builds
SAT Patch Nr: 4945
openSUSE 11.4
  • libsoup-2_4-1 >= 2.32.2-3.4.1
  • libsoup-2_4-1-32bit >= 2.32.2-3.4.1
  • libsoup-2_4-1-debuginfo >= 2.32.2-3.4.1
  • libsoup-2_4-1-debuginfo-32bit >= 2.32.2-3.4.1
Patchnames:
libsoup-2_4-1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES_LTSS-10-SP4 libsoup Affected
SUSE Linux Enterprise Desktop 11 SP1 libsoup Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search libsoup Released
SUSE Linux Enterprise Server 11 SP1 libsoup Released
SUSE Linux Enterprise Server 11 SP1 LTSS libsoup Released
SUSE Linux Enterprise Server for SAP Business All-in-One libsoup Released
SUSE Linux Enterprise Software Development Kit 11 SP1 libsoup Released