Upstream information

CVE-2011-1749 at MITRE

Description

The nfs_addmntent function in support/nfs/nfs_mntent.c in the mount.nsf tool in nfs-utils before 1.2.4 attempts to append to the /etc/mtab file without first checking whether resource limits would interfere, which allows local users to corrupt this file via a process with a small RLIMIT_FSIZE value, a related issue to CVE-2011-1089.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.3
Vector AV:L/AC:M/Au:N/C:N/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 689799 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP1
  • nfs-client >= 1.2.1-2.16.1
  • nfs-kernel-server >= 1.2.1-2.16.1
sles11-sp1.x86
sles11-sp1.x86-64
sles11-sp1.ppc
sled11-sp1.x86
sles11-sp1-vmware.x86
sled11-sp1.x86-64
sles11-sp1.ia64
sles11-sp1-vmware.x86-64
sles11-sp1.s390x
SAT Patch Nr: 4760
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • nfs-client >= 1.2.1-2.16.1
  • nfs-doc >= 1.2.1-2.16.1
  • nfs-kernel-server >= 1.2.1-2.16.1
sles11-sp1.x86
sles11-sp1.x86-64
sles11-sp1.ppc
sled11-sp1.x86
sles11-sp1-vmware.x86
sled11-sp1.x86-64
sles11-sp1.ia64
sles11-sp1-vmware.x86-64
sles11-sp1.s390x
SAT Patch Nr: 4760
openSUSE 11.4
  • nfs-client >= 1.2.3-11.16.1
  • nfs-doc >= 1.2.3-11.16.1
  • nfs-kernel-server >= 1.2.3-11.16.1
openSUSE 11.4
  • nfs-client >= 1.2.3-11.16.1
  • nfs-client-debuginfo >= 1.2.3-11.16.1
  • nfs-doc >= 1.2.3-11.16.1
  • nfs-kernel-server >= 1.2.3-11.16.1
Patchnames:
nfs-client


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 nfs-utils Affected
SUSE Linux Enterprise Desktop 10 SP4 nfs-utils Affected
SUSE Linux Enterprise Desktop 11 SP1 nfs-utils Released
SUSE Linux Enterprise Server 10 SP3 nfs-utils Affected
SUSE Linux Enterprise Server 10 SP4 nfs-utils Affected
SUSE Linux Enterprise Server 10 SP4 LTSS nfs-utils Affected
SUSE Linux Enterprise Server 11 SP1 nfs-utils Released
SUSE Linux Enterprise Server 11 SP1 LTSS nfs-utils Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 nfs-utils Released