Upstream information

CVE-2011-0025 at MITRE

Description

IcedTea 1.7 before 1.7.8, 1.8 before 1.8.5, and 1.9 before 1.9.5 does not properly verify signatures for JAR files that (1) are "partially signed" or (2) signed by multiple entities, which allows remote attackers to trick users into executing code that appears to come from a trusted source.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 667313 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.2
openSUSE 11.3
  • java-1_6_0-openjdk-debuginfo >= 1.6.0.0_b20.1.9.5-1.2.1
  • java-1_6_0-openjdk-debugsource >= 1.6.0.0_b20.1.9.5-1.2.1
  • java-1_6_0-openjdk-devel-debuginfo >= 1.6.0.0_b20.1.9.5-1.2.1
  • java-1_6_0-openjdk-plugin-debuginfo >= 1.6.0.0_b20.1.9.5-1.2.1
openSUSE 11.2
openSUSE 11.3
  • java-1_6_0-openjdk >= 1.6.0.0_b20.1.9.5-1.2.1
  • java-1_6_0-openjdk-demo >= 1.6.0.0_b20.1.9.5-1.2.1
  • java-1_6_0-openjdk-devel >= 1.6.0.0_b20.1.9.5-1.2.1
  • java-1_6_0-openjdk-javadoc >= 1.6.0.0_b20.1.9.5-1.2.1
  • java-1_6_0-openjdk-plugin >= 1.6.0.0_b20.1.9.5-1.2.1
  • java-1_6_0-openjdk-src >= 1.6.0.0_b20.1.9.5-1.2.1