Upstream information

CVE-2010-4528 at MITRE

Description

directconn.c in the MSN protocol plugin in libpurple 2.7.6 through 2.7.8 in Pidgin before 2.7.9 allows remote authenticated users to cause a denial of service (NULL pointer dereference and application crash) via a short p2pv2 packet in a DirectConnect (aka direct connection) session.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 661497 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.2
  • finch-debuginfo >= 2.7.9-1.2.2
  • libpurple-debuginfo >= 2.7.9-1.2.2
  • libpurple-meanwhile-debuginfo >= 2.7.9-1.2.2
  • libpurple-mono-debuginfo >= 2.7.9-1.2.2
  • libpurple-tcl-debuginfo >= 2.7.9-1.2.2
  • pidgin-debuginfo >= 2.7.9-1.2.2
  • pidgin-debugsource >= 2.7.9-1.2.2
  • pidgin-otr-debuginfo >= 3.2.0-142.4.5
  • pidgin-otr-debugsource >= 3.2.0-142.4.5
openSUSE 11.2
  • finch >= 2.7.9-1.2.2
  • finch-devel >= 2.7.9-1.2.2
  • libpurple >= 2.7.9-1.2.2
  • libpurple-devel >= 2.7.9-1.2.2
  • libpurple-lang >= 2.7.9-1.2.2
  • libpurple-meanwhile >= 2.7.9-1.2.2
  • libpurple-mono >= 2.7.9-1.2.2
  • libpurple-tcl >= 2.7.9-1.2.2
  • pidgin >= 2.7.9-1.2.2
  • pidgin-devel >= 2.7.9-1.2.2
  • pidgin-otr >= 3.2.0-142.4.5
openSUSE 11.3
  • finch-debuginfo >= 2.7.9-1.2.1
  • libpurple-debuginfo >= 2.7.9-1.2.1
  • libpurple-meanwhile-debuginfo >= 2.7.9-1.2.1
  • libpurple-mono-debuginfo >= 2.7.9-1.2.1
  • libpurple-tcl-debuginfo >= 2.7.9-1.2.1
  • pidgin-debuginfo >= 2.7.9-1.2.1
  • pidgin-debugsource >= 2.7.9-1.2.1
  • pidgin-otr-debuginfo >= 3.2.0-146.1.2
  • pidgin-otr-debugsource >= 3.2.0-146.1.2
openSUSE 11.3
  • finch >= 2.7.9-1.2.1
  • finch-devel >= 2.7.9-1.2.1
  • libpurple >= 2.7.9-1.2.1
  • libpurple-devel >= 2.7.9-1.2.1
  • libpurple-lang >= 2.7.9-1.2.1
  • libpurple-meanwhile >= 2.7.9-1.2.1
  • libpurple-mono >= 2.7.9-1.2.1
  • libpurple-tcl >= 2.7.9-1.2.1
  • pidgin >= 2.7.9-1.2.1
  • pidgin-devel >= 2.7.9-1.2.1
  • pidgin-otr >= 3.2.0-146.1.2