Upstream information

CVE-2010-4508 at MITRE

Description

The WebSockets implementation in Mozilla Firefox 4 through 4.0 Beta 7 does not properly perform proxy upgrade negotiation, which has unspecified impact and remote attack vectors, related to an "inherent problem" with the WebSocket specification.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 659882 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.1
  • opera >= 11.00-1.1.1
  • opera-gtk >= 11.00-1.1.1
  • opera-kde4 >= 11.00-1.1.1
openSUSE 11.2
openSUSE 11.3
  • opera >= 11.00-1.2.1
  • opera-gtk >= 11.00-1.2.1
  • opera-kde4 >= 11.00-1.2.1