Upstream information

CVE-2010-3316 at MITRE

Description

The run_coprocess function in pam_xauth.c in the pam_xauth module in Linux-PAM (aka pam) before 1.1.2 does not check the return values of the setuid, setgid, and setgroups system calls, which might allow local users to read arbitrary files by executing a program that relies on the pam_xauth PAM check.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.3
Vector AV:L/AC:M/Au:N/C:P/I:P/A:N
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 631802 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • pam >= 1.0.4-0.7.1
  • pam-32bit >= 1.0.4-0.7.1
  • pam-doc >= 1.0.4-0.7.1
  • pam-x86 >= 1.0.4-0.7.1
Patchnames:
slessp1-pam
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • pam >= 0.99.6.3-28.25.4
  • pam-devel >= 0.99.6.3-28.25.4
sles10-sp4.ia64
sles10-sp4-debuginfo.s390x
sles10-sp4.x86-64
sles10-sp4.s390x
sles10-sp4-debuginfo.ppc
sled10-sp4.x86-64
sles10-sp4.ppc
sles10-sp4-debuginfo.ia64
sles10-sp4-debuginfo.x86
sles10-sp4-debuginfo.x86-64
sles10-sp4.x86
sled10-sp4.x86
ZYPP Patch Nr: 7814
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
  • pam >= 0.99.6.3-28.25.4
  • pam-32bit >= 0.99.6.3-28.25.4
  • pam-devel >= 0.99.6.3-28.25.4
sles10-sp4.ia64
sles10-sp4-debuginfo.s390x
sles10-sp4.x86-64
sles10-sp4.s390x
sles10-sp4-debuginfo.ppc
sled10-sp4.x86-64
sles10-sp4.ppc
sles10-sp4-debuginfo.ia64
sles10-sp4-debuginfo.x86
sles10-sp4-debuginfo.x86-64
sles10-sp4.x86
sled10-sp4.x86
ZYPP Patch Nr: 7814
SUSE Linux Enterprise Server 10 SP4 for IPF
  • pam >= 0.99.6.3-28.25.4
  • pam-devel >= 0.99.6.3-28.25.4
  • pam-x86 >= 0.99.6.3-28.25.4
sles10-sp4.ia64
sles10-sp4-debuginfo.s390x
sles10-sp4.x86-64
sles10-sp4.s390x
sles10-sp4-debuginfo.ppc
sled10-sp4.x86-64
sles10-sp4.ppc
sles10-sp4-debuginfo.ia64
sles10-sp4-debuginfo.x86
sles10-sp4-debuginfo.x86-64
sles10-sp4.x86
sled10-sp4.x86
ZYPP Patch Nr: 7814
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • pam >= 0.99.6.3-28.25.4
  • pam-64bit >= 0.99.6.3-28.25.4
  • pam-devel >= 0.99.6.3-28.25.4
  • pam-devel-64bit >= 0.99.6.3-28.25.4
sles10-sp4.ia64
sles10-sp4-debuginfo.s390x
sles10-sp4.x86-64
sles10-sp4.s390x
sles10-sp4-debuginfo.ppc
sled10-sp4.x86-64
sles10-sp4.ppc
sles10-sp4-debuginfo.ia64
sles10-sp4-debuginfo.x86
sles10-sp4-debuginfo.x86-64
sles10-sp4.x86
sled10-sp4.x86
ZYPP Patch Nr: 7814
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • pam >= 0.99.6.3-28.25.4
  • pam-32bit >= 0.99.6.3-28.25.4
  • pam-devel >= 0.99.6.3-28.25.4
  • pam-devel-32bit >= 0.99.6.3-28.25.4
sles10-sp4.ia64
sles10-sp4-debuginfo.s390x
sles10-sp4.x86-64
sles10-sp4.s390x
sles10-sp4-debuginfo.ppc
sled10-sp4.x86-64
sles10-sp4.ppc
sles10-sp4-debuginfo.ia64
sles10-sp4-debuginfo.x86
sles10-sp4-debuginfo.x86-64
sles10-sp4.x86
sled10-sp4.x86
ZYPP Patch Nr: 7814
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • pam >= 0.99.6.3-28.20.3.4
  • pam-32bit >= 0.99.6.3-28.20.3.4
  • pam-devel >= 0.99.6.3-28.20.3.4
  • pam-devel-32bit >= 0.99.6.3-28.20.3.4
sles10-sp3-debuginfo.x86-64
sles10-sp3-debuginfo.x86
sles10-sp3.ppc
sles10-sp3.x86
sles10-sp3.ia64
sles10-sp3-debuginfo.ppc
sles10-sp3-debuginfo.s390x
sles10-sp3.s390x
sles10-sp3.x86-64
sles10-sp3-debuginfo.ia64
ZYPP Patch Nr: 7815
SUSE Linux Enterprise Server 10 SP3
  • pam >= 0.99.6.3-28.20.3.4
  • pam-devel >= 0.99.6.3-28.20.3.4
sles10-sp3-debuginfo.x86-64
sles10-sp3-debuginfo.x86
sles10-sp3.ppc
sles10-sp3.x86
sles10-sp3.ia64
sles10-sp3-debuginfo.ppc
sles10-sp3-debuginfo.s390x
sles10-sp3.s390x
sles10-sp3.x86-64
sles10-sp3-debuginfo.ia64
ZYPP Patch Nr: 7815
SUSE Linux Enterprise Server 10 SP3
  • pam >= 0.99.6.3-28.20.3.4
  • pam-devel >= 0.99.6.3-28.20.3.4
  • pam-x86 >= 0.99.6.3-28.20.3.4
sles10-sp3-debuginfo.x86-64
sles10-sp3-debuginfo.x86
sles10-sp3.ppc
sles10-sp3.x86
sles10-sp3.ia64
sles10-sp3-debuginfo.ppc
sles10-sp3-debuginfo.s390x
sles10-sp3.s390x
sles10-sp3.x86-64
sles10-sp3-debuginfo.ia64
ZYPP Patch Nr: 7815
SUSE Linux Enterprise Server 10 SP3
  • pam >= 0.99.6.3-28.20.3.4
  • pam-64bit >= 0.99.6.3-28.20.3.4
  • pam-devel >= 0.99.6.3-28.20.3.4
  • pam-devel-64bit >= 0.99.6.3-28.20.3.4
sles10-sp3-debuginfo.x86-64
sles10-sp3-debuginfo.x86
sles10-sp3.ppc
sles10-sp3.x86
sles10-sp3.ia64
sles10-sp3-debuginfo.ppc
sles10-sp3-debuginfo.s390x
sles10-sp3.s390x
sles10-sp3.x86-64
sles10-sp3-debuginfo.ia64
ZYPP Patch Nr: 7815
openSUSE 11.3
  • pam-debuginfo >= 1.1.1.90-2.3.1
  • pam-debuginfo-32bit >= 1.1.1.90-2.3.1
  • pam-debugsource >= 1.1.1.90-2.3.1
openSUSE 11.3
  • pam >= 1.1.1.90-2.3.1
  • pam-32bit >= 1.1.1.90-2.3.1
  • pam-devel >= 1.1.1.90-2.3.1
  • pam-devel-32bit >= 1.1.1.90-2.3.1
  • pam-doc >= 1.1.1.90-2.3.1
SUSE Linux Enterprise Software Development Kit 11 SP1
  • pam-devel >= 1.0.4-0.7.1
sles11-sp1.x86-64
sles11-sp1.s390x
sle11-sp1-sdk.ia64
sles11-sp1.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1-vmware.x86-64
sle11-sp1-sdk.s390x
sle11-sp1-sdk.ppc
sles11-sp1.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1.ppc
SAT Patch Nr: 5342
SUSE Linux Enterprise Software Development Kit 11 SP1
  • pam-devel >= 1.0.4-0.7.1
  • pam-devel-32bit >= 1.0.4-0.7.1
sles11-sp1.x86-64
sles11-sp1.s390x
sle11-sp1-sdk.ia64
sles11-sp1.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1-vmware.x86-64
sle11-sp1-sdk.s390x
sle11-sp1-sdk.ppc
sles11-sp1.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1.ppc
SAT Patch Nr: 5342
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • pam >= 1.0.4-0.7.1
  • pam-doc >= 1.0.4-0.7.1
sles11-sp1.x86-64
sles11-sp1.s390x
sle11-sp1-sdk.ia64
sles11-sp1.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1-vmware.x86-64
sle11-sp1-sdk.s390x
sle11-sp1-sdk.ppc
sles11-sp1.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1.ppc
SAT Patch Nr: 5342
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • pam >= 1.0.4-0.7.1
  • pam-32bit >= 1.0.4-0.7.1
  • pam-doc >= 1.0.4-0.7.1
sles11-sp1.x86-64
sles11-sp1.s390x
sle11-sp1-sdk.ia64
sles11-sp1.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1-vmware.x86-64
sle11-sp1-sdk.s390x
sle11-sp1-sdk.ppc
sles11-sp1.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1.ppc
SAT Patch Nr: 5342
SUSE Linux Enterprise Server 11 SP1
  • pam >= 1.0.4-0.7.1
  • pam-doc >= 1.0.4-0.7.1
  • pam-x86 >= 1.0.4-0.7.1
sles11-sp1.x86-64
sles11-sp1.s390x
sle11-sp1-sdk.ia64
sles11-sp1.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1-vmware.x86-64
sle11-sp1-sdk.s390x
sle11-sp1-sdk.ppc
sles11-sp1.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1.ppc
SAT Patch Nr: 5342


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 pam Released
SUSE Linux Enterprise Desktop 10 SP4 pam Released
SUSE Linux Enterprise Desktop 11 SP1 pam Released
SUSE Linux Enterprise SDK 11 SP1 pam Released
SUSE Linux Enterprise Server 10 SP3 pam Released
SUSE Linux Enterprise Server 10 SP4 pam Released
SUSE Linux Enterprise Server 10 SP4 LTSS pam Released
SUSE Linux Enterprise Server 11 SP1 pam Released
SUSE Linux Enterprise Server 11 SP1 LTSS pam Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 pam Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 pam Released