Upstream information

CVE-2010-2441 at MITRE

Description

WebKit does not properly restrict focus changes, which allows remote attackers to read keystrokes via "cross-domain IFRAME gadgets," a different vulnerability than CVE-2010-1126, CVE-2010-1422, and CVE-2010-2295.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 601349 [RESOLVED], 617401 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.2
  • libwebkit-1_0-2-debuginfo >= 1.2.7-0.3.1
  • libwebkit-debugsource >= 1.2.7-0.3.1
  • webkit-jsc-debuginfo >= 1.2.7-0.3.1
openSUSE 11.2
  • libwebkit-1_0-2 >= 1.2.7-0.3.1
  • libwebkit-devel >= 1.2.7-0.3.1
  • libwebkit-lang >= 1.2.7-0.3.1
  • webkit-jsc >= 1.2.7-0.3.1
openSUSE 11.3
  • libwebkit-1_0-2-debuginfo >= 1.2.7-0.2.1
  • libwebkit-1_0-2-debuginfo-32bit >= 1.2.7-0.2.1
  • libwebkit-debugsource >= 1.2.7-0.2.1
  • webkit-jsc-debuginfo >= 1.2.7-0.2.1
openSUSE 11.3
  • libwebkit-1_0-2 >= 1.2.7-0.2.1
  • libwebkit-1_0-2-32bit >= 1.2.7-0.2.1
  • libwebkit-devel >= 1.2.7-0.2.1
  • libwebkit-lang >= 1.2.7-0.2.1
  • webkit-jsc >= 1.2.7-0.2.1
openSUSE 11.2
  • libwebkit-1_0-2-debuginfo >= 1.2.6-0.5.1
  • libwebkit-debugsource >= 1.2.6-0.5.1
  • webkit-jsc-debuginfo >= 1.2.6-0.5.1
openSUSE 11.2
  • libwebkit-1_0-2 >= 1.2.6-0.5.1
  • libwebkit-devel >= 1.2.6-0.5.1
  • libwebkit-lang >= 1.2.6-0.5.1
  • webkit-jsc >= 1.2.6-0.5.1
openSUSE 11.3
  • libwebkit-1_0-2-debuginfo >= 1.2.6-0.2.1
  • libwebkit-1_0-2-debuginfo-32bit >= 1.2.6-0.2.1
  • libwebkit-debugsource >= 1.2.6-0.2.1
  • webkit-jsc-debuginfo >= 1.2.6-0.2.1
openSUSE 11.3
  • libwebkit-1_0-2 >= 1.2.6-0.2.1
  • libwebkit-1_0-2-32bit >= 1.2.6-0.2.1
  • libwebkit-devel >= 1.2.6-0.2.1
  • libwebkit-lang >= 1.2.6-0.2.1
  • webkit-jsc >= 1.2.6-0.2.1
SUSE Linux Enterprise Software Development Kit 11 SP1
  • libwebkit-1_0-2 >= 1.2.7-0.11.4
  • libwebkit-devel >= 1.2.7-0.11.4
  • libwebkit-lang >= 1.2.7-0.11.4
  • webkit-sharp >= 0.2-2.45.3
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.s390x
sle11-sp1-sdk.ia64
sle11-sp1-sdk.ppc
sled11-sp1.x86
SAT Patch Nr: 4765
SUSE Linux Enterprise Software Development Kit 11 SP1
  • libwebkit-1_0-2 >= 1.2.7-0.11.4
  • libwebkit-devel >= 1.2.7-0.11.4
  • libwebkit-lang >= 1.2.7-0.11.4
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.s390x
sle11-sp1-sdk.ia64
sle11-sp1-sdk.ppc
sled11-sp1.x86
SAT Patch Nr: 4765
SUSE Linux Enterprise Desktop 11 SP1
  • libwebkit-1_0-2 >= 1.2.7-0.11.4
  • libwebkit-lang >= 1.2.7-0.11.4
  • webkit-sharp >= 0.2-2.45.3
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.s390x
sle11-sp1-sdk.ia64
sle11-sp1-sdk.ppc
sled11-sp1.x86
SAT Patch Nr: 4765


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 webkit-sharp Released
SUSE Linux Enterprise SDK 11 SP1 webkit-sharp Released