Upstream information

CVE-2010-0827 at MITRE

Description

Integer overflow in dvips in TeX Live 2009 and earlier, and teTeX, allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted virtual font (VF) file associated with a DVI file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 587794 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • texlive-bin-debuginfo >= 2007-176.4
  • texlive-bin-debugsource >= 2007-176.4
openSUSE 11.0
  • texlive >= 2007-177.4
  • texlive-arab >= 2007-177.4
  • texlive-bin >= 2007-176.4
  • texlive-cjk >= 2007-177.4
  • texlive-context >= 2007-177.4
  • texlive-devel >= 2007-177.4
  • texlive-doc >= 2007-177.4
  • texlive-dvilj >= 2007-177.4
  • texlive-jadetex >= 2007-177.4
  • texlive-latex >= 2007-177.4
  • texlive-latex-doc >= 2007-177.4
  • texlive-metapost >= 2007-177.4
  • texlive-musictex >= 2007-177.4
  • texlive-nfs >= 2007-177.4
  • texlive-omega >= 2007-177.4
  • texlive-ppower4 >= 2007-177.4
  • texlive-tex4ht >= 2007-177.4
  • texlive-tools >= 2007-177.4
  • texlive-xetex >= 2007-177.4
  • texlive-xmltex >= 2007-177.4
openSUSE 11.1
  • texlive-bin-debuginfo >= 2007-219.7.1
  • texlive-bin-debugsource >= 2007-219.7.1
openSUSE 11.1
  • texlive >= 2007-219.7.1
  • texlive-arab >= 2007-219.7.1
  • texlive-bin >= 2007-219.7.1
  • texlive-cjk >= 2007-219.7.1
  • texlive-context >= 2007-219.7.1
  • texlive-devel >= 2007-219.7.1
  • texlive-doc >= 2007-219.7.1
  • texlive-dvilj >= 2007-219.7.1
  • texlive-jadetex >= 2007-219.7.1
  • texlive-latex >= 2007-219.7.1
  • texlive-latex-doc >= 2007-219.7.1
  • texlive-metapost >= 2007-219.7.1
  • texlive-musictex >= 2007-219.7.1
  • texlive-nfs >= 2007-219.7.1
  • texlive-omega >= 2007-219.7.1
  • texlive-ppower4 >= 2007-219.7.1
  • texlive-tex4ht >= 2007-219.7.1
  • texlive-tools >= 2007-219.7.1
  • texlive-xetex >= 2007-219.7.1
  • texlive-xmltex >= 2007-219.7.1
openSUSE 11.2
  • texlive-bin-debuginfo >= 2008-13.18.1
  • texlive-bin-debugsource >= 2008-13.18.1
openSUSE 11.2
  • texlive >= 2008-13.18.1
  • texlive-arab >= 2008-13.18.1
  • texlive-bin >= 2008-13.18.1
  • texlive-cjk >= 2008-13.18.1
  • texlive-context >= 2008-13.18.1
  • texlive-devel >= 2008-13.18.1
  • texlive-doc >= 2008-13.18.1
  • texlive-dvilj >= 2008-13.18.1
  • texlive-jadetex >= 2008-13.18.1
  • texlive-latex >= 2008-13.18.1
  • texlive-latex-doc >= 2008-13.18.1
  • texlive-metapost >= 2008-13.18.1
  • texlive-musictex >= 2008-13.18.1
  • texlive-nfs >= 2008-13.18.1
  • texlive-omega >= 2008-13.18.1
  • texlive-ppower4 >= 2008-13.18.1
  • texlive-tex4ht >= 2008-13.18.1
  • texlive-tools >= 2008-13.18.1
  • texlive-xetex >= 2008-13.18.1
  • texlive-xmltex >= 2008-13.18.1
SUSE Linux Enterprise SDK 11 GA
  • texlive >= 2007-219.32.13.1
  • texlive-arab >= 2007-219.32.13.1
  • texlive-cjk >= 2007-219.32.13.1
  • texlive-context >= 2007-219.32.13.1
  • texlive-devel >= 2007-219.32.13.1
  • texlive-doc >= 2007-219.32.13.1
  • texlive-dvilj >= 2007-219.32.13.1
  • texlive-jadetex >= 2007-219.32.13.1
  • texlive-latex >= 2007-219.32.13.1
  • texlive-latex-doc >= 2007-219.32.13.1
  • texlive-metapost >= 2007-219.32.13.1
  • texlive-musictex >= 2007-219.32.13.1
  • texlive-omega >= 2007-219.32.13.1
  • texlive-ppower4 >= 2007-219.32.13.1
  • texlive-tex4ht >= 2007-219.32.13.1
  • texlive-tools >= 2007-219.32.13.1
  • texlive-xetex >= 2007-219.32.13.1
  • texlive-xmltex >= 2007-219.32.13.1
sle11-sdk.ppc
sled11.x86-64
sle11-sdk.ia64
sle11-sdk.s390x
sled11.x86
sle11-sdk.x86-64
sle11-sdk.x86
SAT Patch Nr: 2393
SUSE Linux Enterprise Desktop 11 GA
  • texlive >= 2007-219.32.13.1
  • texlive-cjk >= 2007-219.32.13.1
  • texlive-jadetex >= 2007-219.32.13.1
  • texlive-latex >= 2007-219.32.13.1
  • texlive-tools >= 2007-219.32.13.1
sle11-sdk.ppc
sled11.x86-64
sle11-sdk.ia64
sle11-sdk.s390x
sled11.x86
sle11-sdk.x86-64
sle11-sdk.x86
SAT Patch Nr: 2393
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
SUSE Linux Enterprise SDK 10 SP3
  • te_ams >= 3.0-37.13.1
  • te_cont >= 3.0-37.13.1
  • te_dvilj >= 3.0-37.13.1
  • te_eplai >= 3.0-37.13.1
  • te_kpath >= 3.0-37.13.1
  • te_latex >= 3.0-37.13.1
  • te_mpost >= 3.0-37.13.1
  • te_omega >= 3.0-37.13.1
  • te_ptex >= 3.0-37.13.1
  • te_web >= 3.0-37.13.1
  • tetex >= 3.0-37.13.1
sled10-sp3.x86
sle10-sp3-sdk.ppc
sle10-sp3-sdk.s390x
sle10-sp3-sdk.ia64
sle10-sp3-sdk.x86
sle10-sp3-sdk.x86-64
sled10-sp3.x86-64
ZYPP Patch Nr: 7020


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 GA texlive Released
SUSE Linux Enterprise SDK 11 GA texlive Released