Upstream information

CVE-2010-0163 at MITRE

Description

Mozilla Thunderbird before 2.0.0.24 and SeaMonkey before 1.1.19 process e-mail attachments with a parser that performs casts and line termination incorrectly, which allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted message, related to message indexing.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 590499 [RESOLVED / FIXED], 607935 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • MozillaThunderbird-debuginfo >= 2.0.0.24-0.1
  • MozillaThunderbird-debugsource >= 2.0.0.24-0.1
openSUSE 11.0
  • MozillaThunderbird >= 2.0.0.24-0.1
  • MozillaThunderbird-devel >= 2.0.0.24-0.1
  • MozillaThunderbird-translations >= 2.0.0.24-0.1
openSUSE 11.1
  • MozillaThunderbird-debuginfo >= 2.0.0.24-0.1.1
  • MozillaThunderbird-debugsource >= 2.0.0.24-0.1.1
openSUSE 11.1
  • MozillaThunderbird >= 2.0.0.24-0.1.1
  • MozillaThunderbird-devel >= 2.0.0.24-0.1.1
  • MozillaThunderbird-translations >= 2.0.0.24-0.1.1
openSUSE 11.0
  • seamonkey-debuginfo >= 1.1.19-0.1
  • seamonkey-debugsource >= 1.1.19-0.1
openSUSE 11.0
  • seamonkey >= 1.1.19-0.1
  • seamonkey-dom-inspector >= 1.1.19-0.1
  • seamonkey-irc >= 1.1.19-0.1
  • seamonkey-mail >= 1.1.19-0.1
  • seamonkey-spellchecker >= 1.1.19-0.1
  • seamonkey-venkman >= 1.1.19-0.1
openSUSE 11.1
  • seamonkey-debuginfo >= 1.1.19-0.1.1
  • seamonkey-debugsource >= 1.1.19-0.1.1
openSUSE 11.1
  • seamonkey >= 1.1.19-0.1.1
  • seamonkey-dom-inspector >= 1.1.19-0.1.1
  • seamonkey-irc >= 1.1.19-0.1.1
  • seamonkey-mail >= 1.1.19-0.1.1
  • seamonkey-spellchecker >= 1.1.19-0.1.1
  • seamonkey-venkman >= 1.1.19-0.1.1
Open Enterprise Server
  • mozilla >= 1.8_seamonkey_1.1.19-0.1
  • mozilla-devel >= 1.8_seamonkey_1.1.19-0.1
  • mozilla-dom-inspector >= 1.8_seamonkey_1.1.19-0.1
  • mozilla-irc >= 1.8_seamonkey_1.1.19-0.1
  • mozilla-mail >= 1.8_seamonkey_1.1.19-0.1
  • mozilla-venkman >= 1.8_seamonkey_1.1.19-0.1
core9.ia64
core9.s390x
core9.s390
core9.x86-64
sles9-oes.x86
core9.x86
sles9-nlpos.x86
core9.ppc
YOU Patch Nr: 12616
SLE 11 DESKTOP Unsupported Extras
  • MozillaThunderbird >= 2.0.0.24-0.1.1
  • MozillaThunderbird-translations >= 2.0.0.24-0.1.1
Builds
SAT Patch Nr: 2176