Upstream information

CVE-2009-4271 at MITRE

Description

The Linux kernel 2.6.9 through 2.6.17 on the x86_64 and amd64 platforms allows local users to cause a denial of service (panic) via a 32-bit application that calls mprotect on its Virtual Dynamic Shared Object (VDSO) page and then triggers a segmentation fault.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.7
Vector AV:L/AC:M/Au:N/C:N/I:N/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete

Note from the SUSE Security Team

This problem affects kernels 2.6.9 to 2.6.17, which would imply SLES 10. However it requires the COMPAT_VDSO option specified for the 32bit compatbility mode, which we do not set.
This means that no version of SUSE Linux Enterprise or openSUSE is affected by this problem.,This problem affects kernels 2.6.9 to 2.6.17, which would imply SUSE Linux Enterprise 10. However it requires the COMPAT_VDSO option specified for the 32bit compatbility mode, which we do not set.
This means that no version of SUSE Linux Enterprise or openSUSE is affected by this problem.

SUSE Bugzilla entry: 589036 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.