Upstream information

CVE-2009-3978 at MITRE

Description

The nsGIFDecoder2::GifWrite function in decoders/gif/nsGIFDecoder2.cpp in libpr0n in Mozilla Firefox before 3.5.5 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via an animated GIF file with a large image size, a different vulnerability than CVE-2009-3373.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 553172 [RESOLVED / FIXED], 557686 [RESOLVED / DUPLICATE]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise SDK 10 SP2
  • MozillaFirefox-branding-upstream >= 3.5.5-1.4.1
  • mozilla-xulrunner191-devel >= 1.9.1.5-1.4.1
  • python-xpcom191 >= 1.9.1.5-1.4.1
sle10-sp2-sdk.s390x
sle10-sp2-sdk.ia64
sles10-sp2.x86
sled10-sp2.x86
sle10-sp2-sdk.x86
sles10-sp2-debuginfo.x86-64
sles10-sp2.ppc
sles10-sp2.ia64
sles10-sp2-debuginfo.ia64
sle10-sp2-sdk.x86-64
sles10-sp2-debuginfo.s390x
sled10-sp2.x86-64
sles10-sp2-debuginfo.ppc
sle10-sp2-sdk.ppc
sles10-sp2.x86-64
sles10-sp2-debuginfo.x86
sles10-sp2.s390x
ZYPP Patch Nr: 6665
SUSE Linux Enterprise Desktop 10 SP3 for x86
SUSE Linux Enterprise Server 10 SP3
  • MozillaFirefox >= 3.5.5-1.4.1
  • MozillaFirefox-translations >= 3.5.5-1.4.1
  • mozilla-xulrunner191 >= 1.9.1.5-1.4.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.5-1.4.1
  • mozilla-xulrunner191-translations >= 1.9.1.5-1.4.1
sles10-sp3.x86
sled10-sp3.x86
sle10-sp3-sdk.s390x
sled10-sp3.x86-64
sles10-sp3.ia64
sle10-sp3-sdk.ia64
sles10-sp3-debuginfo.ppc
sles10-sp3.x86-64
sles10-sp3.ppc
sles10-sp3-debuginfo.ia64
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.x86
sle10-sp3-sdk.x86-64
sles10-sp3-debuginfo.s390x
sle10-sp3-sdk.ppc
sles10-sp3.s390x
sles10-sp3-debuginfo.x86-64
ZYPP Patch Nr: 6666
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise SDK 10 SP3
  • MozillaFirefox >= 3.5.5-1.4.1
  • MozillaFirefox-translations >= 3.5.5-1.4.1
  • mozilla-xulrunner191 >= 1.9.1.5-1.4.1
  • mozilla-xulrunner191-32bit >= 1.9.1.5-1.4.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.5-1.4.1
  • mozilla-xulrunner191-gnomevfs-32bit >= 1.9.1.5-1.4.1
  • mozilla-xulrunner191-translations >= 1.9.1.5-1.4.1
  • mozilla-xulrunner191-translations-32bit >= 1.9.1.5-1.4.1
sles10-sp3.x86
sled10-sp3.x86
sle10-sp3-sdk.s390x
sled10-sp3.x86-64
sles10-sp3.ia64
sle10-sp3-sdk.ia64
sles10-sp3-debuginfo.ppc
sles10-sp3.x86-64
sles10-sp3.ppc
sles10-sp3-debuginfo.ia64
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.x86
sle10-sp3-sdk.x86-64
sles10-sp3-debuginfo.s390x
sle10-sp3-sdk.ppc
sles10-sp3.s390x
sles10-sp3-debuginfo.x86-64
ZYPP Patch Nr: 6666
SUSE Linux Enterprise SDK 10 SP3
  • MozillaFirefox-branding-upstream >= 3.5.5-1.4.1
  • mozilla-xulrunner191-devel >= 1.9.1.5-1.4.1
  • python-xpcom191 >= 1.9.1.5-1.4.1
sles10-sp3.x86
sled10-sp3.x86
sle10-sp3-sdk.s390x
sled10-sp3.x86-64
sles10-sp3.ia64
sle10-sp3-sdk.ia64
sles10-sp3-debuginfo.ppc
sles10-sp3.x86-64
sles10-sp3.ppc
sles10-sp3-debuginfo.ia64
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.x86
sle10-sp3-sdk.x86-64
sles10-sp3-debuginfo.s390x
sle10-sp3-sdk.ppc
sles10-sp3.s390x
sles10-sp3-debuginfo.x86-64
ZYPP Patch Nr: 6666
SUSE Linux Enterprise SDK 11 GA
  • mozilla-xulrunner191-devel >= 1.9.1.5-1.3.1
sles11.ia64
sle11-sdk.ia64
sle11-sdk.ppc
sled11.x86-64
sle11-debuginfo.ia64
sles11.x86-64
sle11-sdk.x86-64
sle11-debuginfo.x86-64
sled11.x86
sle11-sdk.s390x
sle11-debuginfo.s390x
sle11-debuginfo.ppc
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-debuginfo.x86
sles11.ppc
SAT Patch Nr: 1563
SUSE Linux Enterprise SDK 11 GA
  • mozilla-xulrunner191-devel >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-gnomevfs-x86 >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-translations-x86 >= 1.9.1.5-1.3.1
sles11.ia64
sle11-sdk.ia64
sle11-sdk.ppc
sled11.x86-64
sle11-debuginfo.ia64
sles11.x86-64
sle11-sdk.x86-64
sle11-debuginfo.x86-64
sled11.x86
sle11-sdk.s390x
sle11-debuginfo.s390x
sle11-debuginfo.ppc
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-debuginfo.x86
sles11.ppc
SAT Patch Nr: 1563
SUSE Linux Enterprise SDK 11 GA
  • mozilla-xulrunner191-devel >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-gnomevfs-32bit >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-translations-32bit >= 1.9.1.5-1.3.1
sles11.ia64
sle11-sdk.ia64
sle11-sdk.ppc
sled11.x86-64
sle11-debuginfo.ia64
sles11.x86-64
sle11-sdk.x86-64
sle11-debuginfo.x86-64
sled11.x86
sle11-sdk.s390x
sle11-debuginfo.s390x
sle11-debuginfo.ppc
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-debuginfo.x86
sles11.ppc
SAT Patch Nr: 1563
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • MozillaFirefox >= 3.5.5-1.1.2
  • MozillaFirefox-translations >= 3.5.5-1.1.2
  • mozilla-xulrunner191 >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-translations >= 1.9.1.5-1.3.1
sles11.ia64
sle11-sdk.ia64
sle11-sdk.ppc
sled11.x86-64
sle11-debuginfo.ia64
sles11.x86-64
sle11-sdk.x86-64
sle11-debuginfo.x86-64
sled11.x86
sle11-sdk.s390x
sle11-debuginfo.s390x
sle11-debuginfo.ppc
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-debuginfo.x86
sles11.ppc
SAT Patch Nr: 1563
SUSE Linux Enterprise Desktop 11 GA
  • MozillaFirefox >= 3.5.5-1.1.2
  • MozillaFirefox-translations >= 3.5.5-1.1.2
  • mozilla-xulrunner191 >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-32bit >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-gnomevfs-32bit >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-translations >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-translations-32bit >= 1.9.1.5-1.3.1
sles11.ia64
sle11-sdk.ia64
sle11-sdk.ppc
sled11.x86-64
sle11-debuginfo.ia64
sles11.x86-64
sle11-sdk.x86-64
sle11-debuginfo.x86-64
sled11.x86
sle11-sdk.s390x
sle11-debuginfo.s390x
sle11-debuginfo.ppc
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-debuginfo.x86
sles11.ppc
SAT Patch Nr: 1563
SUSE Linux Enterprise Server 11 GA
  • MozillaFirefox >= 3.5.5-1.1.2
  • MozillaFirefox-translations >= 3.5.5-1.1.2
  • mozilla-xulrunner191 >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-translations >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-x86 >= 1.9.1.5-1.3.1
sles11.ia64
sle11-sdk.ia64
sle11-sdk.ppc
sled11.x86-64
sle11-debuginfo.ia64
sles11.x86-64
sle11-sdk.x86-64
sle11-debuginfo.x86-64
sled11.x86
sle11-sdk.s390x
sle11-debuginfo.s390x
sle11-debuginfo.ppc
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-debuginfo.x86
sles11.ppc
SAT Patch Nr: 1563
SUSE Linux Enterprise Server 11 GA
  • MozillaFirefox >= 3.5.5-1.1.2
  • MozillaFirefox-translations >= 3.5.5-1.1.2
  • mozilla-xulrunner191 >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-32bit >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.5-1.3.1
  • mozilla-xulrunner191-translations >= 1.9.1.5-1.3.1
sles11.ia64
sle11-sdk.ia64
sle11-sdk.ppc
sled11.x86-64
sle11-debuginfo.ia64
sles11.x86-64
sle11-sdk.x86-64
sle11-debuginfo.x86-64
sled11.x86
sle11-sdk.s390x
sle11-debuginfo.s390x
sle11-debuginfo.ppc
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-debuginfo.x86
sles11.ppc
SAT Patch Nr: 1563
openSUSE 11.2
  • MozillaFirefox-debuginfo >= 3.5.5-1.1.2
  • MozillaFirefox-debugsource >= 3.5.5-1.1.2
  • mozilla-xulrunner191-debuginfo >= 1.9.1.5-1.2.1
  • mozilla-xulrunner191-debuginfo-32bit >= 1.9.1.5-1.2.1
  • mozilla-xulrunner191-debugsource >= 1.9.1.5-1.2.1
  • mozilla-xulrunner191-kde4-debuginfo >= 0.6-0.1.1
  • mozilla-xulrunner191-kde4-debugsource >= 0.6-0.1.1
  • python-xpcom191-debuginfo >= 1.9.1.5-1.2.1
openSUSE 11.2
  • MozillaFirefox >= 3.5.5-1.1.2
  • MozillaFirefox-branding-upstream >= 3.5.5-1.1.2
  • MozillaFirefox-translations-common >= 3.5.5-1.1.2
  • MozillaFirefox-translations-other >= 3.5.5-1.1.2
  • mozilla-xulrunner191 >= 1.9.1.5-1.2.1
  • mozilla-xulrunner191-32bit >= 1.9.1.5-1.2.1
  • mozilla-xulrunner191-devel >= 1.9.1.5-1.2.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.5-1.2.1
  • mozilla-xulrunner191-gnomevfs-32bit >= 1.9.1.5-1.2.1
  • mozilla-xulrunner191-kde4 >= 0.6-0.1.1
  • mozilla-xulrunner191-translations-common >= 1.9.1.5-1.2.1
  • mozilla-xulrunner191-translations-other >= 1.9.1.5-1.2.1
  • python-xpcom191 >= 1.9.1.5-1.2.1