Upstream information

CVE-2009-3609 at MITRE

Description

Integer overflow in the ImageStream::ImageStream function in Stream.cc in Xpdf before 3.02pl4 and Poppler before 0.12.1, as used in GPdf, kdegraphics KPDF, and CUPS pdftops, allows remote attackers to cause a denial of service (application crash) via a crafted PDF document that triggers a NULL pointer dereference or buffer over-read.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 539875 [RESOLVED / FIXED], 546400 [RESOLVED / FIXED], 546404 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise SDK 10 SP2
  • xpdf >= 3.01-21.22.2
ZYPP Patch Nr: 6556
SUSE Linux Enterprise Server for SAP 10 SP2
  • cups >= 1.1.23-40.57.2
  • cups-client >= 1.1.23-40.57.2
  • cups-devel >= 1.1.23-40.57.2
  • cups-libs >= 1.1.23-40.57.2
  • cups-libs-32bit >= 1.1.23-40.57.2
Builds
ZYPP Patch Nr: 6720
SLES SDK 9 for IBM S/390 and IBM zSeries
SLES SDK 9 for IBM iSeries and IBM pSeries
SLES SDK 9 for IBM zSeries
SLES SDK 9 for IPF
SLES SDK 9 for X86-64
SLES SDK 9 for x86
  • xpdf >= 3.00-64.54
  • xpdf-config >= 3.00-64.54
Builds
YOU Patch Nr: 12523
openSUSE 11.0
  • kdegraphics3-pdf >= 3.5.9-53.5
openSUSE 11.1
  • kdegraphics3-pdf >= 3.5.10-1.64.1
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • cups >= 1.1.20-108.63
  • cups-client >= 1.1.20-108.63
  • cups-devel >= 1.1.20-108.63
  • cups-libs >= 1.1.20-108.63
Builds
YOU Patch Nr: 12561
Novell Linux Desktop 9 for x86_64
  • cups >= 1.1.20-108.63
  • cups-client >= 1.1.20-108.63
  • cups-devel >= 1.1.20-108.63
  • cups-libs >= 1.1.20-108.63
  • cups-libs-32bit >= 9-200912011928
Builds
YOU Patch Nr: 12561
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
  • kdegraphics3-pdf >= 3.5.1-23.26.1
Builds
ZYPP Patch Nr: 6652
SUSE Linux Enterprise Desktop 10 SP3 for x86
SUSE Linux Enterprise Server 10 SP3
  • cups >= 1.1.23-40.59.8
  • cups-client >= 1.1.23-40.59.8
  • cups-devel >= 1.1.23-40.59.8
  • cups-libs >= 1.1.23-40.59.8
Builds
ZYPP Patch Nr: 6721
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
  • cups >= 1.1.23-40.59.8
  • cups-client >= 1.1.23-40.59.8
  • cups-devel >= 1.1.23-40.59.8
  • cups-libs >= 1.1.23-40.59.8
  • cups-libs-32bit >= 1.1.23-40.59.8
Builds
ZYPP Patch Nr: 6721
SUSE Linux Enterprise Server 10 SP3
  • cups >= 1.1.23-40.59.8
  • cups-client >= 1.1.23-40.59.8
  • cups-devel >= 1.1.23-40.59.8
  • cups-libs >= 1.1.23-40.59.8
  • cups-libs-x86 >= 1.1.23-40.59.8
Builds
ZYPP Patch Nr: 6721
SUSE Linux Enterprise Server 10 SP3
  • cups >= 1.1.23-40.59.8
  • cups-client >= 1.1.23-40.59.8
  • cups-devel >= 1.1.23-40.59.8
  • cups-libs >= 1.1.23-40.59.8
  • cups-libs-64bit >= 1.1.23-40.59.8
Builds
ZYPP Patch Nr: 6721
openSUSE 11.0
  • xpdf-debuginfo >= 3.02-95.9
  • xpdf-debugsource >= 3.02-95.9
openSUSE 11.0
  • xpdf >= 3.02-95.9
  • xpdf-tools >= 3.02-95.9
openSUSE 11.1
  • xpdf-debuginfo >= 3.02-97.81.3
  • xpdf-debugsource >= 3.02-97.81.3
openSUSE 11.1
  • xpdf >= 3.02-97.81.3
  • xpdf-tools >= 3.02-97.81.3
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
  • xpdf-tools >= 3.01-21.23.2
Builds
ZYPP Patch Nr: 6560
SUSE Linux Enterprise SDK 10 SP3
  • xpdf >= 3.01-21.23.2
Builds
ZYPP Patch Nr: 6560


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 cups Released
SLED-10-SP3 xpdf Released
SLES-10-SP3 cups Released
SLES-10-SP3 xpdf Released
SUSE Linux Enterprise Desktop 11 cups Affected
SUSE Linux Enterprise Software Development Kit 11 cups Affected