Upstream information

CVE-2009-3009 at MITRE

Description

Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 535913 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.1
  • rubygem-actionpack-2_1 >= 2.1.1-2.24.1
SUSE Linux Enterprise SDK 11 GA
  • rubygem-actionpack-2_1 >= 2.1.2-1.3.2
sle11-sdk.ia64
sle11-sdk.s390x
sle11-sdk.x86
sle11-sdk.ppc
sle11-sdk.x86-64
SAT Patch Nr: 1317
SUSE Linux Enterprise SDK 11 GA
  • rubygem-activesupport-2_1 >= 2.1.2-1.3.1
sle11-sdk.x86
sle11-sdk.ia64
sle11-sdk.s390x
sle11-sdk.x86-64
sle11-sdk.ppc
SAT Patch Nr: 1318
openSUSE 11.1
  • rubygem-activesupport-2_1 >= 2.1.1-2.24.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 GA rubygem-actionpack-2_1 Released
SUSE Linux Enterprise SDK 11 SP1 rubygem-actionpack-2_1 Released
SUSE Linux Enterprise SDK 11 SP2 rubygem-actionpack-2_1 Released