Upstream information

CVE-2009-2632 at MITRE

Description

Buffer overflow in the SIEVE script component (sieve/script.c), as used in cyrus-imapd in Cyrus IMAP Server 2.2.13 and 2.3.14, and Dovecot 1.0 before 1.0.4 and 1.1 before 1.1.7, allows local users to execute arbitrary code and read or modify arbitrary messages via a crafted SIEVE script, related to the incorrect use of the sizeof operator for determining buffer length, combined with an integer signedness error.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.4
Vector AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 537128 [RESOLVED / FIXED], 539876 [RESOLVED / FIXED], 539877 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • dovecot-debuginfo >= 1.0.13-24.4
  • dovecot-debugsource >= 1.0.13-24.4
openSUSE 11.0
  • dovecot >= 1.0.13-24.4
  • dovecot-devel >= 1.0.13-24.4
openSUSE 11.1
  • dovecot11-debuginfo >= 1.1.7-1.4.1
  • dovecot11-debugsource >= 1.1.7-1.4.1
openSUSE 11.1
  • dovecot11 >= 1.1.7-1.4.1
  • dovecot11-backend-mysql >= 1.1.7-1.4.1
  • dovecot11-backend-pgsql >= 1.1.7-1.4.1
  • dovecot11-backend-sqlite >= 1.1.7-1.4.1
  • dovecot11-devel >= 1.1.7-1.4.1
  • dovecot11-fts-lucene >= 1.1.7-1.4.1
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • perl-Cyrus-IMAP >= 2.2.3-83.40
  • perl-Cyrus-SIEVE-managesieve >= 2.2.3-83.40
core9.ppc
sles9-nld.x86
core9.ia64
core9.x86-64
sles9-nld.x86-64
core9.s390x
core9.s390
core9.x86
sles9-oes.x86
sles9-nlpos.x86
YOU Patch Nr: 12502
Open Enterprise Server
  • cyrus-imapd >= 2.2.3-83.40
  • cyrus-imapd-devel >= 2.2.3-83.40
  • perl-Cyrus-IMAP >= 2.2.3-83.40
  • perl-Cyrus-SIEVE-managesieve >= 2.2.3-83.40
core9.ppc
sles9-nld.x86
core9.ia64
core9.x86-64
sles9-nld.x86-64
core9.s390x
core9.s390
core9.x86
sles9-oes.x86
sles9-nlpos.x86
YOU Patch Nr: 12502
openSUSE 11.0
  • cyrus-imapd-debuginfo >= 2.3.11-31.2
  • cyrus-imapd-debugsource >= 2.3.11-31.2
openSUSE 11.0
  • cyrus-imapd >= 2.3.11-31.2
  • cyrus-imapd-devel >= 2.3.11-31.2
  • perl-Cyrus-IMAP >= 2.3.11-31.2
  • perl-Cyrus-SIEVE-managesieve >= 2.3.11-31.2
openSUSE 11.1
  • cyrus-imapd-debuginfo >= 2.3.11-60.20.2
  • cyrus-imapd-debugsource >= 2.3.11-60.20.2
openSUSE 11.1
  • cyrus-imapd >= 2.3.11-60.20.2
  • cyrus-imapd-devel >= 2.3.11-60.20.2
  • perl-Cyrus-IMAP >= 2.3.11-60.20.2
  • perl-Cyrus-SIEVE-managesieve >= 2.3.11-60.20.2
SUSE Linux Enterprise SDK 10 SP2
  • cyrus-imapd >= 2.2.12-27.13.2
  • cyrus-imapd-devel >= 2.2.12-27.13.2
  • perl-Cyrus-IMAP >= 2.2.12-27.13.2
  • perl-Cyrus-SIEVE-managesieve >= 2.2.12-27.13.2
sles10-sp2.x86-64
sles10-sp2-debuginfo.ia64
sles10-sp2-debuginfo.x86-64
sles10-sp2.s390x
sle10-sp2-sdk.x86-64
sle10-sp2-sdk.s390x
sle10-sp2-sdk.ia64
sles10-sp2-debuginfo.s390x
sles10-sp2-debuginfo.ppc
sles10-sp2-debuginfo.x86
sle10-sp2-sdk.ppc
sles10-sp2.ia64
sles10-sp2.x86
sle10-sp2-sdk.x86
sles10-sp2.ppc
ZYPP Patch Nr: 6476
SUSE Linux Enterprise SDK 11 GA
  • cyrus-imapd-devel >= 2.3.11-60.20.2
  • perl-Cyrus-IMAP >= 2.3.11-60.20.2
  • perl-Cyrus-SIEVE-managesieve >= 2.3.11-60.20.2
sles11.x86-64
sle11-debuginfo.x86-64
sle11-debuginfo.ppc
sle11-sdk.x86
sles11.ia64
sles11.ppc
sles11.s390x
sle11-sdk.x86-64
sle11-debuginfo.ia64
sle11-debuginfo.x86
sles11.x86
sle11-sdk.ppc
sle11-debuginfo.s390x
sle11-sdk.s390x
sle11-sdk.ia64
SAT Patch Nr: 1284
SUSE Linux Enterprise SDK 11 GA
  • cyrus-imapd-devel >= 2.3.11-60.20.2
sles11.x86-64
sle11-debuginfo.x86-64
sle11-debuginfo.ppc
sle11-sdk.x86
sles11.ia64
sles11.ppc
sles11.s390x
sle11-sdk.x86-64
sle11-debuginfo.ia64
sle11-debuginfo.x86
sles11.x86
sle11-sdk.ppc
sle11-debuginfo.s390x
sle11-sdk.s390x
sle11-sdk.ia64
SAT Patch Nr: 1284
SUSE Linux Enterprise Server 11 GA
  • cyrus-imapd >= 2.3.11-60.20.2
  • perl-Cyrus-IMAP >= 2.3.11-60.20.2
  • perl-Cyrus-SIEVE-managesieve >= 2.3.11-60.20.2
sles11.x86-64
sle11-debuginfo.x86-64
sle11-debuginfo.ppc
sle11-sdk.x86
sles11.ia64
sles11.ppc
sles11.s390x
sle11-sdk.x86-64
sle11-debuginfo.ia64
sle11-debuginfo.x86
sles11.x86
sle11-sdk.ppc
sle11-debuginfo.s390x
sle11-sdk.s390x
sle11-sdk.ia64
SAT Patch Nr: 1284


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 GA cyrus-imapd Released
SUSE Linux Enterprise SDK 11 SP1 cyrus-imapd Released
SUSE Linux Enterprise SDK 11 SP2 cyrus-imapd Released
SUSE Linux Enterprise SDK 11 SP3 cyrus-imapd Released
SUSE Linux Enterprise SDK 11 SP4 cyrus-imapd Released
SUSE Linux Enterprise Server 10 SP3 cyrus-imapd Released
SUSE Linux Enterprise Server 11 SP1 cyrus-imapd Released
SUSE Linux Enterprise Server 11 SP1 LTSS cyrus-imapd Released
SUSE Linux Enterprise Server 11 SP2 cyrus-imapd Released
SUSE Linux Enterprise Server 11 SP2 LTSS cyrus-imapd Released
SUSE Linux Enterprise Server 11 SP3 cyrus-imapd Released
SUSE Linux Enterprise Server 11 SP3 LTSS cyrus-imapd Released
SUSE Linux Enterprise Server 11 SP4 cyrus-imapd Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 cyrus-imapd Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 cyrus-imapd Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 cyrus-imapd Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 cyrus-imapd Released
SUSE Linux Enterprise Server for VMWare 11 SP2 cyrus-imapd Released
SUSE Linux Enterprise Server for VMWare 11 SP3 cyrus-imapd Released