Upstream information

CVE-2009-1684 at MITRE

Description

Cross-site scripting (XSS) vulnerability in WebKit in Apple Safari before 4.0, iPhone OS 1.0 through 2.2.1, and iPhone OS for iPod touch 1.1 through 2.2.1 allows remote attackers to inject arbitrary web script or HTML via an event handler that triggers script execution in the context of the next loaded document.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 601349 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.2
  • libwebkit-1_0-2-debuginfo >= 1.2.6-0.5.1
  • libwebkit-debugsource >= 1.2.6-0.5.1
  • webkit-jsc-debuginfo >= 1.2.6-0.5.1
openSUSE 11.2
  • libwebkit-1_0-2 >= 1.2.6-0.5.1
  • libwebkit-devel >= 1.2.6-0.5.1
  • libwebkit-lang >= 1.2.6-0.5.1
  • webkit-jsc >= 1.2.6-0.5.1
openSUSE 11.3
  • libwebkit-1_0-2-debuginfo >= 1.2.6-0.2.1
  • libwebkit-1_0-2-debuginfo-32bit >= 1.2.6-0.2.1
  • libwebkit-debugsource >= 1.2.6-0.2.1
  • webkit-jsc-debuginfo >= 1.2.6-0.2.1
openSUSE 11.3
  • libwebkit-1_0-2 >= 1.2.6-0.2.1
  • libwebkit-1_0-2-32bit >= 1.2.6-0.2.1
  • libwebkit-devel >= 1.2.6-0.2.1
  • libwebkit-lang >= 1.2.6-0.2.1
  • webkit-jsc >= 1.2.6-0.2.1