Upstream information

CVE-2009-0756 at MITRE

Description

The JBIG2Stream::readSymbolDictSeg function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file that triggers a parsing error, which is not properly handled by JBIG2SymbolDict::~JBIG2SymbolDict and triggers an invalid memory dereference.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 475556 [RESOLVED / DUPLICATE], 481795 [RESOLVED / FIXED], 487100 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
  • libpoppler4 >= 0.10.1-1.30.5
Patchnames:
slessp0-libpoppler4
SUSE Linux Enterprise Server 11 SP1
  • libpoppler-glib4 >= 0.12.3-1.2.44
  • libpoppler-qt4-3 >= 0.12.3-1.2.44
  • libpoppler5 >= 0.12.3-1.2.44
  • poppler-tools >= 0.12.3-1.2.44
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA libpoppler-glib4
SUSE Linux Enterprise Server 11 SP2
  • libpoppler-glib4 >= 0.12.3-1.3.1
  • libpoppler-qt4-3 >= 0.12.3-1.3.1
  • libpoppler5 >= 0.12.3-1.3.1
  • poppler-tools >= 0.12.3-1.3.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libpoppler-glib4
SUSE Linux Enterprise Server 11 SP3
  • libpoppler-glib4 >= 0.12.3-1.8.1
  • libpoppler-qt4-3 >= 0.12.3-1.8.1
  • libpoppler5 >= 0.12.3-1.8.1
  • poppler-tools >= 0.12.3-1.8.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libpoppler-glib4
SUSE Linux Enterprise Server 11 SP4
  • libpoppler-glib4 >= 0.12.3-1.10.1
  • libpoppler-qt4-3 >= 0.12.3-1.10.1
  • libpoppler5 >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libpoppler-glib4
SUSE Linux Enterprise Server for SAP Applications 11
  • libpoppler4 >= 0.10.1-1.30.5
Patchnames:
slessp0-libpoppler4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libpoppler-devel >= 0.12.3-1.10.1
  • libpoppler-glib-devel >= 0.12.3-1.10.1
  • libpoppler-qt2 >= 0.12.3-1.10.1
  • libpoppler-qt3-devel >= 0.12.3-1.10.1
  • libpoppler-qt4-devel >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libpoppler-devel
openSUSE 11.0
  • libpoppler3 >= 0.8.2-1.4
openSUSE 11.1
  • libpoppler4 >= 0.10.1-1.6.10
SUSE Linux Enterprise SDK 10 SP2
  • poppler-devel >= 0.4.4-19.23
sles10-sp2.x86-64
sle10-sp2-sdk.ia64
sles10-sp2.ppc
sled10-sp2.x86-64
sle10-sp2-sdk.s390x
sled10-sp2.x86
sles10-sp2.x86
sle10-sp2-sdk.ppc
sles10-sp2.ia64
sle10-sp2-sdk.x86
sle10-sp2-sdk.x86-64
sles10-sp2.s390x
ZYPP Patch Nr: 6315
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • libpoppler4 >= 0.10.1-1.30.5
sles11.x86
sles11.s390x
sles11.ia64
sled11.x86-64
sles11.x86-64
sles11.ppc
sled11.x86
SAT Patch Nr: 1034


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 GA poppler Released
SUSE Linux Enterprise SDK 11 GA poppler Released
SUSE Linux Enterprise Server 11 GA poppler Released