Upstream information

CVE-2008-3972 at MITRE

Description

pkcs15-tool in OpenSC before 0.11.6 does not apply security updates to a smart card unless the card's label matches the "OpenSC" string, which might allow physically proximate attackers to exploit vulnerabilities that the card owner expected were patched, as demonstrated by exploitation of CVE-2008-2235.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.6
Vector AV:L/AC:L/Au:N/C:N/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 413496 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise SDK 10 SP2
  • opensc-devel >= 0.9.6-17.9
Builds
ZYPP Patch Nr: 5588
SUSE Linux Enterprise SDK 10 SP2
  • opensc-32bit >= 0.9.6-17.9
  • opensc-devel >= 0.9.6-17.9
Builds
ZYPP Patch Nr: 5588
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • opensc >= 0.8.0-194.6
  • opensc-devel >= 0.8.0-194.6
Builds
ZYPP Patch Nr: 5588
openSUSE 11.0
  • opensc-debuginfo >= 0.11.4-37.4
  • opensc-debugsource >= 0.11.4-37.4
openSUSE 11.0
  • libopensc2 >= 0.11.4-37.4
  • libopensc2-32bit >= 0.11.4-37.4
  • libopensc2-64bit >= 0.11.4-37.4
  • opensc >= 0.11.4-37.4
  • opensc-32bit >= 0.11.4-37.4
  • opensc-64bit >= 0.11.4-37.4
  • opensc-devel >= 0.11.4-37.4