Upstream information

CVE-2008-3889 at MITRE

Description

Postfix 2.4 before 2.4.9, 2.5 before 2.5.5, and 2.6 before 2.6-20080902, when used with the Linux 2.6 kernel, leaks epoll file descriptors during execution of "non-Postfix" commands, which allows local users to cause a denial of service (application slowdown or exit) via a crafted command, as demonstrated by a command in a .forward file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 421847 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • postfix-debuginfo >= 2.5.1-28.5
  • postfix-debugsource >= 2.5.1-28.5
openSUSE 11.0
  • postfix >= 2.5.1-28.5
  • postfix-devel >= 2.5.1-28.5
  • postfix-mysql >= 2.5.1-28.5
  • postfix-postgresql >= 2.5.1-28.5