Upstream information

CVE-2008-3281 at MITRE

Description

libxml2 2.6.32 and earlier does not properly detect recursion during entity expansion in an attribute value, which allows context-dependent attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 415371 [RESOLVED / FIXED], 422636 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 SDK for x86
Novell Linux Desktop 9 SDK for x86_64
SLES SDK 9 for IBM S/390 and IBM zSeries
SLES SDK 9 for IBM iSeries and IBM pSeries
SLES SDK 9 for IBM zSeries
SLES SDK 9 for IPF
SLES SDK 9 for X86-64
SLES SDK 9 for x86
  • libxml2-python >= 2.6.7-46.14
Builds
ZYPP Patch Nr: 5583
Novell Linux Desktop 9 for x86
  • libxml2 >= 2.6.7-28.14
  • libxml2-devel >= 2.6.7-28.14
  • libxml2-python >= 2.6.7-46.14
Builds
ZYPP Patch Nr: 5583
Novell Linux Desktop 9 for x86_64
  • libxml2 >= 2.6.7-28.14
  • libxml2-32bit >= 9-200809051309
  • libxml2-devel >= 2.6.7-28.14
  • libxml2-python >= 2.6.7-46.14
Builds
ZYPP Patch Nr: 5583
Open Enterprise Server
  • libxml2 >= 2.6.7-28.14
  • libxml2-devel >= 2.6.7-28.14
Builds
ZYPP Patch Nr: 5583
openSUSE 11.0
  • libxml2-debuginfo >= 2.6.32-11.3
  • libxml2-debugsource >= 2.6.32-11.3
openSUSE 11.0
  • libxml2 >= 2.6.32-11.3
  • libxml2-32bit >= 2.6.32-11.3
  • libxml2-64bit >= 2.6.32-11.3
  • libxml2-devel >= 2.6.32-11.3
  • libxml2-devel-32bit >= 2.6.32-11.3
  • libxml2-devel-64bit >= 2.6.32-11.3
  • libxml2-doc >= 2.6.32-11.3