Upstream information

CVE-2008-3115 at MITRE

Description

Secure Static Versioning in Sun Java JDK and JRE 6 Update 6 and earlier, and 5.0 Update 6 through 15, does not properly prevent execution of applets on older JRE releases, which might allow remote attackers to exploit vulnerabilities in these older releases.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 407935 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • java-1_6_0-sun >= 1.6.0.u7-1.1
  • java-1_6_0-sun-alsa >= 1.6.0.u7-1.1
  • java-1_6_0-sun-debuginfo >= 1.6.0.u7-1.1
  • java-1_6_0-sun-demo >= 1.6.0.u7-1.1
  • java-1_6_0-sun-devel >= 1.6.0.u7-1.1
  • java-1_6_0-sun-jdbc >= 1.6.0.u7-1.1
  • java-1_6_0-sun-plugin >= 1.6.0.u7-1.1
openSUSE 11.0
  • java-1_5_0-sun >= 1.5.0_update16-1.1
  • java-1_5_0-sun-alsa >= 1.5.0_update16-1.1
  • java-1_5_0-sun-demo >= 1.5.0_update16-1.1
  • java-1_5_0-sun-devel >= 1.5.0_update16-1.1
  • java-1_5_0-sun-jdbc >= 1.5.0_update16-1.1
  • java-1_5_0-sun-plugin >= 1.5.0_update16-1.1
  • java-1_5_0-sun-src >= 1.5.0_update16-1.1