Upstream information

CVE-2008-2667 at MITRE

Description

SQL injection vulnerability in the Courier Authentication Library (aka courier-authlib) before 0.60.6 on SUSE openSUSE 10.3 and 11.0, and other platforms, when MySQL and a non-Latin character set are used, allows remote attackers to execute arbitrary SQL commands via the username and unspecified other vectors.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.1
Vector AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 398412 [RESOLVED / FIXED], 457238 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • courier-authlib >= 0.60.2-40.2
  • courier-authlib-devel >= 0.60.2-40.2
  • courier-authlib-ldap >= 0.60.2-40.2
  • courier-authlib-mysql >= 0.60.2-40.2
  • courier-authlib-pgsql >= 0.60.2-40.2
  • courier-authlib-pipe >= 0.60.2-40.2
  • courier-authlib-userdb >= 0.60.2-40.2