Upstream information

CVE-2008-2380 at MITRE

Description

SQL injection vulnerability in authpgsqllib.c in Courier-Authlib before 0.62.0, when a non-Latin locale Postgres database is used, allows remote attackers to execute arbitrary SQL commands via query parameters containing apostrophes.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.1
Vector AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 457238 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.1
  • courier-authlib >= 0.61.0-1.21.1
  • courier-authlib-debuginfo >= 0.61.0-1.21.1
  • courier-authlib-debugsource >= 0.61.0-1.21.1
  • courier-authlib-devel >= 0.61.0-1.21.1
  • courier-authlib-ldap >= 0.61.0-1.21.1
  • courier-authlib-mysql >= 0.61.0-1.21.1
  • courier-authlib-pgsql >= 0.61.0-1.21.1
  • courier-authlib-pipe >= 0.61.0-1.21.1
  • courier-authlib-userdb >= 0.61.0-1.21.1
openSUSE 11.1
  • courier-authlib >= 0.61.0-1.21.1
  • courier-authlib-devel >= 0.61.0-1.21.1
  • courier-authlib-ldap >= 0.61.0-1.21.1
  • courier-authlib-mysql >= 0.61.0-1.21.1
  • courier-authlib-pgsql >= 0.61.0-1.21.1
  • courier-authlib-pipe >= 0.61.0-1.21.1
  • courier-authlib-userdb >= 0.61.0-1.21.1
openSUSE 11.0
  • courier-authlib-debuginfo >= 0.60.2-40.4
  • courier-authlib-debugsource >= 0.60.2-40.4
openSUSE 11.0
  • courier-authlib >= 0.60.2-40.4
  • courier-authlib-devel >= 0.60.2-40.4
  • courier-authlib-ldap >= 0.60.2-40.4
  • courier-authlib-mysql >= 0.60.2-40.4
  • courier-authlib-pgsql >= 0.60.2-40.4
  • courier-authlib-pipe >= 0.60.2-40.4
  • courier-authlib-userdb >= 0.60.2-40.4
openSUSE 11.1
  • courier-authlib >= 0.61.0-1.1
  • courier-authlib-debuginfo >= 0.61.0-1.1
  • courier-authlib-debugsource >= 0.61.0-1.1
  • courier-authlib-devel >= 0.61.0-1.1
  • courier-authlib-ldap >= 0.61.0-1.1
  • courier-authlib-mysql >= 0.61.0-1.1
  • courier-authlib-pgsql >= 0.61.0-1.1
  • courier-authlib-pipe >= 0.61.0-1.1
  • courier-authlib-userdb >= 0.61.0-1.1
openSUSE 11.1
  • courier-authlib >= 0.61.0-1.1
  • courier-authlib-devel >= 0.61.0-1.1
  • courier-authlib-ldap >= 0.61.0-1.1
  • courier-authlib-mysql >= 0.61.0-1.1
  • courier-authlib-pgsql >= 0.61.0-1.1
  • courier-authlib-pipe >= 0.61.0-1.1
  • courier-authlib-userdb >= 0.61.0-1.1