Upstream information

CVE-2008-2234 at MITRE

Description

Multiple buffer overflows in Openwsman 1.2.0 and 2.0.0 allow remote attackers to execute arbitrary code via a crafted "Authorization: Basic" HTTP header.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
No SUSE Bugzilla entries cross referenced.

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • openwsman-debuginfo >= 2.0.0-3.3
  • openwsman-debugsource >= 2.0.0-3.3
openSUSE 11.0
  • libwsman-devel >= 2.0.0-3.3
  • libwsman1 >= 2.0.0-3.3
  • openwsman-client >= 2.0.0-3.3
  • openwsman-python >= 2.0.0-3.3
  • openwsman-ruby >= 2.0.0-3.3
  • openwsman-server >= 2.0.0-3.3