Upstream information

CVE-2008-1927 at MITRE

Description

Double free vulnerability in Perl 5.8.8 allows context-dependent attackers to cause a denial of service (memory corruption and crash) via a crafted regular expression containing UTF8 characters. NOTE: this issue might only be present on certain operating systems.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 381901 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • perl >= 5.8.3-32.14
sles10-sp2.ppc
core9.x86-64
sles10.x86
core9.s390
sles10.ppc
sled10-sp2.x86
sles10-sp2.s390x
sles10.x86-64
sles10.ia64
sles10-sp2.x86
sles10-sp2.x86-64
core9.x86
sles10.s390x
sled10.x86
sles9-nld.x86
core9.ppc
sled10-sp2.x86-64
core9.s390x
sled10.x86-64
sles9-nlpos.x86
sles10-sp2.ia64
core9.ia64
sles9-nld.x86-64
sles9-oes.x86
ZYPP Patch Nr: 5444
Novell Linux Desktop 9 for x86_64
  • perl >= 5.8.3-32.14
  • perl-32bit >= 9-200807111457
sles10-sp2.ppc
core9.x86-64
sles10.x86
core9.s390
sles10.ppc
sled10-sp2.x86
sles10-sp2.s390x
sles10.x86-64
sles10.ia64
sles10-sp2.x86
sles10-sp2.x86-64
core9.x86
sles10.s390x
sled10.x86
sles9-nld.x86
core9.ppc
sled10-sp2.x86-64
core9.s390x
sled10.x86-64
sles9-nlpos.x86
sles10-sp2.ia64
core9.ia64
sles9-nld.x86-64
sles9-oes.x86
ZYPP Patch Nr: 5444
openSUSE 11.0
  • perl >= 5.10.0-37.4
  • perl-32bit >= 5.10.0-37.4
  • perl-64bit >= 5.10.0-37.4
  • perl-base >= 5.10.0-37.4
  • perl-doc >= 5.10.0-37.4