Upstream information

CVE-2007-4965 at MITRE

Description

Multiple integer overflows in the imageop module in Python 2.5.1 and earlier allow context-dependent attackers to cause a denial of service (application crash) and possibly obtain sensitive information (memory contents) via crafted arguments to (1) the tovideo method, and unspecified other vectors related to (2) imageop.c, (3) rbgimgmodule.c, and other files, which trigger heap-based buffer overflows.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 325649 [RESOLVED / FIXED], 377090 [RESOLVED / FIXED], 444989 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • python >= 2.3.3-88.20
  • python-curses >= 2.3.3-88.20
  • python-demo >= 2.3.3-88.20
  • python-devel >= 2.3.3-88.20
  • python-doc >= 2.3.3-88.20
  • python-doc-pdf >= 2.3.3-88.20
  • python-gdbm >= 2.3.3-88.20
  • python-idle >= 2.3.3-88.20
  • python-mpz >= 2.3.3-88.20
  • python-tk >= 2.3.3-88.20
  • python-xml >= 2.3.3-88.20
sles10.x86
sles10.ppc
sles10.s390x
sles10.ia64
core9.x86
core9.s390
sles10.x86-64
ZYPP Patch Nr: 4902
Novell Linux Desktop 9 for x86_64
  • python >= 2.3.3-88.20
  • python-32bit >= 9-200801101709
  • python-curses >= 2.3.3-88.20
  • python-demo >= 2.3.3-88.20
  • python-devel >= 2.3.3-88.20
  • python-doc >= 2.3.3-88.20
  • python-doc-pdf >= 2.3.3-88.20
  • python-gdbm >= 2.3.3-88.20
  • python-idle >= 2.3.3-88.20
  • python-mpz >= 2.3.3-88.20
  • python-tk >= 2.3.3-88.20
  • python-xml >= 2.3.3-88.20
sles10.x86
sles10.ppc
sles10.s390x
sles10.ia64
core9.x86
core9.s390
sles10.x86-64
ZYPP Patch Nr: 4902
SUSE LINUX 10.1
  • python >= 2.4.2-18.13
  • python-32bit >= 2.4.2-18.13
  • python-64bit >= 2.4.2-18.13
  • python-curses >= 2.4.2-18.13
  • python-demo >= 2.4.2-18.13
  • python-devel >= 2.4.2-18.13
  • python-gdbm >= 2.4.2-18.13
  • python-idle >= 2.4.2-18.13
  • python-tk >= 2.4.2-18.13
  • python-xml >= 2.4.2-18.13