Upstream information

CVE-2007-4137 at MITRE

Description

Off-by-one error in the QUtf8Decoder::toUnicode function in Trolltech Qt 3 allows context-dependent attackers to cause a denial of service (crash) via a crafted Unicode string that triggers a heap-based buffer overflow. NOTE: Qt 4 has the same error in the QUtf8Codec::convertToUnicode function, but it is not exploitable.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 304249 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
SUSE LINUX 10.0
  • qt3 >= 3.3.4-28.14
  • qt3-32bit >= 3.3.4-28.14
  • qt3-64bit >= 3.3.4-28.14
  • qt3-devel >= 3.3.4-28.14
  • qt3-devel-32bit >= 3.3.4-28.14
  • qt3-devel-64bit >= 3.3.4-28.14
  • qt3-devel-doc >= 3.3.4-28.14
  • qt3-devel-tools >= 3.3.4-28.10
  • qt3-static >= 3.3.4-28.14
SUSE LINUX 10.1
  • qt3 >= 3.3.5-58.32
  • qt3-32bit >= 3.3.5-58.32
  • qt3-64bit >= 3.3.5-58.32
  • qt3-devel >= 3.3.5-58.32
  • qt3-devel-32bit >= 3.3.5-58.32
  • qt3-devel-64bit >= 3.3.5-58.32
  • qt3-devel-doc >= 3.3.5-58.29
  • qt3-devel-tools >= 3.3.5-58.29
  • qt3-devel-tools-64bit >= 3.3.5-58.29
  • qt3-static >= 3.3.5-58.26
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • qt3 >= 3.3.1-36.31
  • qt3-devel >= 3.3.1-36.31
  • qt3-devel-doc >= 3.3.1-36.31
  • qt3-devel-tools >= 3.3.1-35.24
  • qt3-non-mt >= 3.3.1-41.29
Builds
ZYPP Patch Nr: 4420
Novell Linux Desktop 9 for x86_64
  • qt3 >= 3.3.1-36.31
  • qt3-32bit >= 9-200709191359
  • qt3-devel >= 3.3.1-36.31
  • qt3-devel-32bit >= 9-200709191359
  • qt3-devel-doc >= 3.3.1-36.31
  • qt3-devel-tools >= 3.3.1-35.24
  • qt3-non-mt >= 3.3.1-41.29
Builds
ZYPP Patch Nr: 4420
SLES SDK 9 for IBM S/390 and IBM zSeries
SLES SDK 9 for IBM iSeries and IBM pSeries
SLES SDK 9 for IBM zSeries
SLES SDK 9 for IPF
SLES SDK 9 for X86-64
SLES SDK 9 for x86
  • qt3-static >= 3.3.1-41.25
Builds
ZYPP Patch Nr: 4420