Upstream information

CVE-2007-2867 at MITRE

Description

Multiple vulnerabilities in the layout engine for Mozilla Firefox 1.5.x before 1.5.0.12 and 2.x before 2.0.0.4, Thunderbird 1.5.x before 1.5.0.12 and 2.x before 2.0.0.4, and SeaMonkey 1.0.9 and 1.1.2 allow remote attackers to cause a denial of service (crash) via vectors related to dangling pointers, heap corruption, signed/unsigned, and other issues.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 271197 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
  • mozilla >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-cs >= 1.8_seamonkey_1.0.4-0.5
  • mozilla-deat >= 1.8_seamonkey_1.0.4-0.5
  • mozilla-devel >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-dom-inspector >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-hu >= 1.80_seamonkey_1.0.4-3
  • mozilla-irc >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-mail >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-venkman >= 1.8_seamonkey_1.0.9-1.2
core9.s390
core9.x86
YOU Patch Nr: 11551
Novell Linux Desktop 9 for x86_64
  • mozilla >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-cs >= 1.8_seamonkey_1.0.4-0.5
  • mozilla-deat >= 1.8_seamonkey_1.0.4-0.5
  • mozilla-devel >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-dom-inspector >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-hu >= 1.80_seamonkey_1.0.4-3
  • mozilla-irc >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-lib64 >= 1.6-0.9
  • mozilla-mail >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-venkman >= 1.8_seamonkey_1.0.9-1.2
core9.s390
core9.x86
YOU Patch Nr: 11551
Open Enterprise Server
  • mozilla >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-calendar >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-cs >= 1.8_seamonkey_1.0.4-0.5
  • mozilla-deat >= 1.8_seamonkey_1.0.4-0.5
  • mozilla-devel >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-dom-inspector >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-hu >= 1.80_seamonkey_1.0.4-3
  • mozilla-irc >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-mail >= 1.8_seamonkey_1.0.9-1.2
  • mozilla-venkman >= 1.8_seamonkey_1.0.9-1.2
core9.s390
core9.x86
YOU Patch Nr: 11551
SUSE LINUX 10.1
  • seamonkey >= 1.0.9-1.1
  • seamonkey-calendar >= 1.0.9-1.1
  • seamonkey-dom-inspector >= 1.0.9-1.1
  • seamonkey-irc >= 1.0.9-1.1
  • seamonkey-mail >= 1.0.9-1.1
  • seamonkey-spellchecker >= 1.0.9-1.1
  • seamonkey-venkman >= 1.0.9-1.1
SUSE LINUX 10.1
  • MozillaFirefox >= 2.0.0.4-1.2
  • MozillaFirefox-translations >= 2.0.0.4-1.2
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • mozilla >= 1.8_seamonkey_1.0.9-0.3
  • mozilla-calendar >= 1.8_seamonkey_1.0.9-0.3
  • mozilla-devel >= 1.8_seamonkey_1.0.9-0.3
  • mozilla-dom-inspector >= 1.8_seamonkey_1.0.9-0.3
  • mozilla-irc >= 1.8_seamonkey_1.0.9-0.3
  • mozilla-mail >= 1.8_seamonkey_1.0.9-0.3
  • mozilla-spellchecker >= 1.8_seamonkey_1.0.9-0.3
  • mozilla-venkman >= 1.8_seamonkey_1.0.9-0.3
  • mozilla-xmlterm >= 1.8_seamonkey_1.0.9-0.3
ul1.s390
slrs8.x86
YOU Patch Nr: 11547
SUSE LINUX 10.0
  • MozillaThunderbird >= 1.5.0.12-1.2
SUSE LINUX 10.0
  • mozilla >= 1.8_seamonkey_1.0.9-2.3
  • mozilla-calendar >= 1.8_seamonkey_1.0.9-2.3
  • mozilla-devel >= 1.8_seamonkey_1.0.9-2.3
  • mozilla-dom-inspector >= 1.8_seamonkey_1.0.9-2.3
  • mozilla-irc >= 1.8_seamonkey_1.0.9-2.3
  • mozilla-ko >= 1.75-3.3
  • mozilla-mail >= 1.8_seamonkey_1.0.9-2.3
  • mozilla-spellchecker >= 1.8_seamonkey_1.0.9-2.3
  • mozilla-venkman >= 1.8_seamonkey_1.0.9-2.3
  • mozilla-zh-CN >= 1.7-6.3
  • mozilla-zh-TW >= 1.7-6.3
SUSE LINUX 10.1
  • MozillaThunderbird >= 1.5.0.12-2.2
  • MozillaThunderbird-translations >= 1.5.0.12-2.2
SUSE LINUX 10.0
  • MozillaFirefox >= 2.0.0.4-1.1
  • MozillaFirefox-translations >= 2.0.0.4-1.1
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • MozillaFirefox >= 1.5.0.12-0.1
  • MozillaFirefox-translations >= 1.5.0.12-0.1
Builds
YOU Patch Nr: 11546