Upstream information

CVE-2007-2589 at MITRE

Description

Cross-site request forgery (CSRF) vulnerability in compose.php in SquirrelMail 1.4.0 through 1.4.9a allows remote attackers to send e-mails from arbitrary users via certain data in the SRC attribute of an IMG element.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 279841 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • squirrelmail >= 1.4.10a-17.2
SUSE LINUX 10.1
  • squirrelmail >= 1.4.10a-17.1
SUSE LINUX 10.0
  • squirrelmail >= 1.4.5-5.15
SUSE LINUX 10.1
  • squirrelmail >= 1.4.5-18.10