Upstream information

CVE-2007-2022 at MITRE

Description

Adobe Macromedia Flash Player 7 and 9, when used with Opera before 9.20 or Konqueror before 20070613, allows remote attackers to obtain sensitive information (browser keystrokes), which are leaked to the Flash Player applet.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 257905 [RESOLVED / FIXED], 264218 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • flash-player >= 7.0.70.0-0.1
Builds
ZYPP Patch Nr: 3890
SUSE LINUX 10.0
SUSE LINUX 10.1
SUSE LINUX 9.3
  • opera >= 9.20-1.1
SUSE LINUX 10.0
  • flash-player >= 7.0.70.0-0.1
SUSE LINUX 10.1
  • flash-player >= 9.0.48.0-1.2
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • kdebase3 >= 3.2.1-68.59
core9.s390
sles9-nld.x86
YOU Patch Nr: 11526
Novell Linux Desktop 9 for x86_64
  • kdebase3 >= 3.2.1-68.59
  • kdebase3-32bit >= 9-200705221253
core9.s390
sles9-nld.x86
YOU Patch Nr: 11526
SuSE Linux Desktop 1.0
  • netscape-plugins >= 7.0.70-0.1
slrs8.x86
SUSE LINUX Retail Solution 8
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • netscape-plugins >= 4.80-116
slrs8.x86
SUSE LINUX 10.0
  • kdebase3 >= 3.4.2-27.6
  • kdebase3-32bit >= 3.4.2-27.6
  • kdebase3-64bit >= 3.4.2-27.6
SUSE LINUX 10.1
  • kdebase3 >= 3.5.1-69.35.3
  • kdebase3-32bit >= 3.5.1-69.35.3
  • kdebase3-64bit >= 3.5.1-69.35.3
SUSE LINUX 9.3
  • kdebase3 >= 3.4.0-28.6
  • kdebase3-32bit >= 9.3-7.2