Upstream information

CVE-2007-1824 at MITRE

Description

Buffer overflow in the php_stream_filter_create function in PHP 5 before 5.2.1 allows remote attackers to cause a denial of service (application crash) via a php://filter/ URL that has a name ending in the '.' character.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.1
Vector AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 259754 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • apache2-mod_php5 >= 5.0.4-9.27
  • php5 >= 5.0.4-9.27
  • php5-bcmath >= 5.0.4-9.27
  • php5-bz2 >= 5.0.4-9.27
  • php5-calendar >= 5.0.4-9.27
  • php5-ctype >= 5.0.4-9.27
  • php5-curl >= 5.0.4-9.27
  • php5-dbase >= 5.0.4-9.27
  • php5-dbx >= 5.0.4-9.27
  • php5-devel >= 5.0.4-9.27
  • php5-dio >= 5.0.4-9.27
  • php5-dom >= 5.0.4-9.27
  • php5-exif >= 5.0.4-9.27
  • php5-fam >= 5.0.4-9.27
  • php5-fastcgi >= 5.0.4-9.27
  • php5-filepro >= 5.0.4-9.27
  • php5-ftp >= 5.0.4-9.27
  • php5-gd >= 5.0.4-9.27
  • php5-gettext >= 5.0.4-9.27
  • php5-gmp >= 5.0.4-9.27
  • php5-iconv >= 5.0.4-9.27
  • php5-imap >= 5.0.4-9.27
  • php5-ldap >= 5.0.4-9.27
  • php5-mbstring >= 5.0.4-9.27
  • php5-mcrypt >= 5.0.4-9.27
  • php5-mhash >= 5.0.4-9.27
  • php5-mysql >= 5.0.4-9.27
  • php5-mysqli >= 5.0.4-9.27
  • php5-ncurses >= 5.0.4-9.27
  • php5-odbc >= 5.0.4-9.27
  • php5-openssl >= 5.0.4-9.27
  • php5-pcntl >= 5.0.4-9.27
  • php5-pear >= 5.0.4-9.27
  • php5-pgsql >= 5.0.4-9.27
  • php5-posix >= 5.0.4-9.27
  • php5-pspell >= 5.0.4-9.27
  • php5-shmop >= 5.0.4-9.27
  • php5-snmp >= 5.0.4-9.27
  • php5-soap >= 5.0.4-9.27
  • php5-sockets >= 5.0.4-9.27
  • php5-sqlite >= 5.0.4-9.27
  • php5-sysvmsg >= 5.0.4-9.27
  • php5-sysvsem >= 5.0.4-9.27
  • php5-sysvshm >= 5.0.4-9.27
  • php5-tokenizer >= 5.0.4-9.27
  • php5-wddx >= 5.0.4-9.27
  • php5-xmlrpc >= 5.0.4-9.27
  • php5-xsl >= 5.0.4-9.27
  • php5-yp >= 5.0.4-9.27
  • php5-zlib >= 5.0.4-9.27
SUSE LINUX 9.3
  • apache2-mod_php5 >= 5.0.3-14.37
  • php5 >= 5.0.3-14.37
  • php5-bcmath >= 5.0.3-14.37
  • php5-bz2 >= 5.0.3-14.37
  • php5-calendar >= 5.0.3-14.37
  • php5-ctype >= 5.0.3-14.37
  • php5-curl >= 5.0.3-14.37
  • php5-dba >= 5.0.3-14.37
  • php5-dbase >= 5.0.3-14.37
  • php5-dbx >= 5.0.3-14.37
  • php5-devel >= 5.0.3-14.37
  • php5-dio >= 5.0.3-14.37
  • php5-dom >= 5.0.3-14.37
  • php5-exif >= 5.0.3-14.37
  • php5-fam >= 5.0.3-14.37
  • php5-fastcgi >= 5.0.3-14.37
  • php5-filepro >= 5.0.3-14.37
  • php5-ftp >= 5.0.3-14.37
  • php5-gd >= 5.0.3-14.37
  • php5-gettext >= 5.0.3-14.37
  • php5-gmp >= 5.0.3-14.37
  • php5-iconv >= 5.0.3-14.37
  • php5-imap >= 5.0.3-14.37
  • php5-ldap >= 5.0.3-14.37
  • php5-mbstring >= 5.0.3-14.37
  • php5-mcrypt >= 5.0.3-14.37
  • php5-mhash >= 5.0.3-14.37
  • php5-mysql >= 5.0.3-14.37
  • php5-mysqli >= 5.0.3-14.37
  • php5-ncurses >= 5.0.3-14.37
  • php5-odbc >= 5.0.3-14.37
  • php5-openssl >= 5.0.3-14.37
  • php5-pcntl >= 5.0.3-14.37
  • php5-pear >= 5.0.3-14.37
  • php5-pgsql >= 5.0.3-14.37
  • php5-posix >= 5.0.3-14.37
  • php5-readline >= 5.0.3-14.37
  • php5-shmop >= 5.0.3-14.37
  • php5-snmp >= 5.0.3-14.37
  • php5-soap >= 5.0.3-14.37
  • php5-sockets >= 5.0.3-14.37
  • php5-sqlite >= 5.0.3-14.37
  • php5-sysvmsg >= 5.0.3-14.37
  • php5-sysvsem >= 5.0.3-14.37
  • php5-sysvshm >= 5.0.3-14.37
  • php5-tokenizer >= 5.0.3-14.37
  • php5-wddx >= 5.0.3-14.37
  • php5-xmlrpc >= 5.0.3-14.37
  • php5-xsl >= 5.0.3-14.37
  • php5-yp >= 5.0.3-14.37
  • php5-zlib >= 5.0.3-14.37