Upstream information

CVE-2007-0556 at MITRE

Description

The query planner in PostgreSQL before 8.0.11, 8.1 before 8.1.7, and 8.2 before 8.2.2 does not verify that a table is compatible with a "previously made query plan," which allows remote authenticated users to cause a denial of service (server crash) and possibly access database content via an "ALTER COLUMN TYPE" SQL statement, which can be leveraged to read arbitrary memory from the server.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.6
Vector AV:N/AC:H/Au:S/C:C/I:N/A:C
Access Vector Network
Access Complexity High
Authentication Single
Confidentiality Impact Complete
Integrity Impact None
Availability Impact Complete
SUSE Bugzilla entry: 242162 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • postgresql >= 8.0.13-2.1
  • postgresql-contrib >= 8.0.13-2.1
  • postgresql-devel >= 8.0.13-2.1
  • postgresql-docs >= 8.0.13-2.1
  • postgresql-libs >= 8.0.13-2.1
  • postgresql-libs-32bit >= 8.0.13-2.1
  • postgresql-libs-64bit >= 8.0.13-2.1
  • postgresql-pl >= 8.0.13-2.1
  • postgresql-server >= 8.0.13-2.1
SUSE LINUX 10.1
  • postgresql >= 8.1.9-1.2
  • postgresql-contrib >= 8.1.9-1.2
  • postgresql-devel >= 8.1.9-1.2
  • postgresql-docs >= 8.1.9-1.2
  • postgresql-libs >= 8.1.9-1.2
  • postgresql-libs-32bit >= 8.1.9-1.2
  • postgresql-libs-64bit >= 8.1.9-1.2
  • postgresql-pl >= 8.1.9-1.2
  • postgresql-server >= 8.1.9-1.2
SUSE LINUX 9.3
  • postgresql >= 8.0.13-1.1
  • postgresql-contrib >= 8.0.13-1.1
  • postgresql-devel >= 8.0.13-1.1
  • postgresql-docs >= 8.0.13-1.1
  • postgresql-libs >= 8.0.13-1.1
  • postgresql-libs-32bit >= 9.3-7.5
  • postgresql-pl >= 8.0.13-1.1
  • postgresql-server >= 8.0.13-1.1
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • postgresql >= 7.4.17-0.1
  • postgresql-contrib >= 7.4.17-0.1
  • postgresql-devel >= 7.4.17-0.1
  • postgresql-docs >= 7.4.17-0.1
  • postgresql-libs >= 7.4.17-0.1
  • postgresql-pl >= 7.4.17-0.1
  • postgresql-server >= 7.4.17-0.1
core9.s390
sles10.s390x
sles10.x86
sles9-oes.x86
ZYPP Patch Nr: 3244
Novell Linux Desktop 9 for x86_64
  • postgresql >= 7.4.17-0.1
  • postgresql-contrib >= 7.4.17-0.1
  • postgresql-devel >= 7.4.17-0.1
  • postgresql-docs >= 7.4.17-0.1
  • postgresql-libs >= 7.4.17-0.1
  • postgresql-libs-32bit >= 9-200704271846
  • postgresql-pl >= 7.4.17-0.1
  • postgresql-server >= 7.4.17-0.1
core9.s390
sles10.s390x
sles10.x86
sles9-oes.x86
ZYPP Patch Nr: 3244