Upstream information

CVE-2006-4809 at MITRE

Description

Stack-based buffer overflow in loader_pnm.c in imlib2 before 1.2.1, and possibly other versions, allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted PNM image.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.1
Vector AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 214313 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • imlib2-loaders >= 1.1.1-9.3
SUSE LINUX 10.1
  • imlib2-loaders >= 1.2.1-17.7
SUSE LINUX 9.2
  • imlib2-loaders >= 1.1.1-2.5
SUSE LINUX 9.3
  • imlib2-loaders >= 1.1.1-7.3
SUSE LINUX 10.0
  • imlib2-loaders >= 1.1.1-9.4
SUSE LINUX 10.1
  • imlib2-loaders >= 1.2.1-17.9
SUSE LINUX 9.2
  • imlib2-loaders >= 1.1.1-2.6
SUSE LINUX 9.3
  • imlib2-loaders >= 1.1.1-7.4