Upstream information

CVE-2006-4519 at MITRE

Description

Multiple integer overflows in the image loader plug-ins in GIMP before 2.2.16 allow user-assisted remote attackers to execute arbitrary code via crafted length values in (1) DICOM, (2) PNM, (3) PSD, (4) PSP, (5) Sun RAS, (6) XBM, and (7) XWD files.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 290591 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SuSE Linux Desktop 1.0
  • gimp >= 1.2.3-548
core9.s390
core9.x86
ZYPP Patch Nr: 3993
Novell Linux Desktop 9 SDK for x86
Novell Linux Desktop 9 SDK for x86_64
Novell Linux Desktop 9 for x86_64
  • gimp >= 2.0.2-1.11
  • gimp-devel >= 2.0.2-1.11
core9.s390
core9.x86
ZYPP Patch Nr: 3993
Novell Linux Desktop 9 for x86
  • gimp >= 2.0.2-1.11
core9.s390
core9.x86
ZYPP Patch Nr: 3993
SLES SDK 9 for IBM S/390 and IBM zSeries
SLES SDK 9 for IBM iSeries and IBM pSeries
SLES SDK 9 for IBM zSeries
SLES SDK 9 for IPF
SLES SDK 9 for X86-64
SLES SDK 9 for x86
  • gimp >= 2.0.0-16.15
  • gimp-devel >= 2.0.0-16.15
core9.s390
core9.x86
ZYPP Patch Nr: 3993
SUSE LINUX 10.0
  • gimp >= 2.2.8-6.10
  • gimp-devel >= 2.2.8-6.10
  • gimp-unstable >= 2.3.3-5.9
  • gimp-unstable-devel >= 2.3.3-5.9
SUSE LINUX 10.1
  • gimp >= 2.2.10-22.29
  • gimp-devel >= 2.2.10-22.29
  • gimp-unstable >= 2.3.7-17.9
  • gimp-unstable-devel >= 2.3.7-17.9