Upstream information

CVE-2006-4340 at MITRE

Description

Mozilla Network Security Service (NSS) library before 3.11.3, as used in Mozilla Firefox before 1.5.0.7, Thunderbird before 1.5.0.7, and SeaMonkey before 1.0.5, when using an RSA key with exponent 3, does not properly handle extra data in a signature, which allows remote attackers to forge signatures for SSL/TLS and email certificates, a similar vulnerability to CVE-2006-4339. NOTE: on 20061107, Mozilla released an advisory stating that these versions were not completely patched by MFSA2006-60. The newer fixes for 1.5.0.7 are covered by CVE-2006-5462.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:H/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 203781 [RESOLVED / FIXED], 205678 [RESOLVED / FIXED], 214895 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
SUSE LINUX 9.2
SUSE LINUX 9.3
  • MozillaFirefox >= 1.5.0.7-1.1
  • MozillaFirefox-translations >= 1.5.0.7-1.1
SUSE LINUX 10.1
  • MozillaFirefox >= 1.5.0.7-1.2
  • MozillaFirefox-translations >= 1.5.0.7-1.2
SUSE LINUX 10.0
SUSE LINUX 9.2
SUSE LINUX 9.3
  • MozillaThunderbird >= 1.5.0.7-0.1
SUSE LINUX 10.1
  • MozillaThunderbird >= 1.5.0.7-0.1
  • MozillaThunderbird-translations >= 1.5.0.7-0.1
SUSE LINUX 10.0
  • mozilla-nss >= 3.10-12.3
  • mozilla-nss-32bit >= 3.10-12.3
  • mozilla-nss-64bit >= 3.10-12.3
  • mozilla-nss-devel >= 3.10-12.3
SUSE LINUX 10.1
  • mozilla-nss >= 3.11-21.7
  • mozilla-nss-32bit >= 3.11-21.7
  • mozilla-nss-64bit >= 3.11-21.7
  • mozilla-nss-devel >= 3.11-21.7
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • MozillaFirefox >= 1.5.0.7-1.2
  • MozillaFirefox-translations >= 1.5.0.7-1.2
sles10.s390x
sled10.x86
sles10.ia64
ZYPP Patch Nr: 2088
SUSE Linux Enterprise Desktop 10 SP1 for x86
  • MozillaFirefox >= 2.0.0.2-2.13
  • MozillaFirefox-translations >= 2.0.0.2-2.13
  • dejavu >= 2.9-0.10
  • desktop-data-NLD >= 10.1-31.24
  • mozilla-nss >= 3.11.4-0.7
  • mozilla-nss-devel >= 3.11.4-0.7
  • mozilla-nss-tools >= 3.11.4-0.7
  • openmotif-libs >= 2.2.4-21.12
  • sax2 >= 7.1-125.37
  • sax2-gui >= 1.7-125.37
  • sax2-ident >= 1.7-125.38
  • sax2-libsax >= 7.1-125.37
  • sax2-libsax-csharp >= 7.1-121.37
  • sax2-libsax-perl >= 7.1-125.37
  • sax2-tools >= 2.7-125.37
  • tightvnc >= 1.2.9-201.12
  • xdg-menu >= 0.2-66.10
  • xorg-x11-driver-video >= 6.9.0-46.40
  • xorg-x11-driver-video-nvidia >= 6.9.0-46.40
  • yast2-control-center >= 2.13.10-0.8
  • yast2-qt >= 2.13.82-0.3
  • yast2-x11 >= 2.13.13-0.4
sles10.ia64
sles10.ppc
sles10.x86-64
sles10.x86
sles10.s390x
ZYPP Patch Nr: 2777
SUSE Linux Enterprise Desktop 10 SP1 for AMD64 and Intel EM64T
  • MozillaFirefox >= 2.0.0.2-2.13
  • MozillaFirefox-translations >= 2.0.0.2-2.13
  • dejavu >= 2.9-0.10
  • desktop-data-NLD >= 10.1-31.24
  • mozilla-nss >= 3.11.4-0.7
  • mozilla-nss-32bit >= 3.11.4-0.7
  • mozilla-nss-devel >= 3.11.4-0.7
  • mozilla-nss-tools >= 3.11.4-0.7
  • openmotif-libs >= 2.2.4-21.12
  • openmotif-libs-32bit >= 2.2.4-21.12
  • sax2 >= 7.1-125.37
  • sax2-gui >= 1.7-125.37
  • sax2-ident >= 1.7-125.38
  • sax2-libsax >= 7.1-125.37
  • sax2-libsax-csharp >= 7.1-121.37
  • sax2-libsax-perl >= 7.1-125.37
  • sax2-tools >= 2.7-125.37
  • tightvnc >= 1.2.9-201.12
  • xdg-menu >= 0.2-66.10
  • xorg-x11-driver-video >= 6.9.0-46.40
  • xorg-x11-driver-video-nvidia >= 6.9.0-46.40
  • yast2-control-center >= 2.13.10-0.8
  • yast2-qt >= 2.13.82-0.3
  • yast2-x11 >= 2.13.13-0.4
sles10.ia64
sles10.ppc
sles10.x86-64
sles10.x86
sles10.s390x
ZYPP Patch Nr: 2777
SUSE Linux Enterprise Server 10 SP1 for x86
  • MozillaFirefox >= 2.0.0.2-2.13
  • MozillaFirefox-translations >= 2.0.0.2-2.13
  • dejavu >= 2.9-0.10
  • desktop-data-NLD >= 10.1-31.24
  • mozilla-nss >= 3.11.4-0.7
  • mozilla-nss-devel >= 3.11.4-0.7
  • openmotif >= 2.2.4-21.12
  • openmotif-demo >= 2.2.4-21.12
  • openmotif-devel >= 2.2.4-21.12
  • openmotif-libs >= 2.2.4-21.12
  • sax2 >= 7.1-125.37
  • sax2-gui >= 1.7-125.37
  • sax2-ident >= 1.7-125.38
  • sax2-libsax >= 7.1-125.37
  • sax2-libsax-devel >= 7.1-125.37
  • sax2-libsax-java >= 7.1-125.37
  • sax2-libsax-perl >= 7.1-125.37
  • sax2-libsax-python >= 7.1-125.37
  • sax2-tools >= 2.7-125.37
  • tightvnc >= 1.2.9-201.12
  • xdg-menu >= 0.2-66.10
  • xorg-x11-driver-video >= 6.9.0-46.40
  • xorg-x11-driver-video-nvidia >= 6.9.0-46.40
  • yast2-control-center >= 2.13.10-0.8
  • yast2-qt >= 2.13.82-0.3
  • yast2-x11 >= 2.13.13-0.4
sles10.ia64
sles10.ppc
sles10.x86-64
sles10.x86
sles10.s390x
ZYPP Patch Nr: 2777
SUSE Linux Enterprise Server 10 SP1 for IPF
  • MozillaFirefox >= 2.0.0.2-2.13
  • MozillaFirefox-translations >= 2.0.0.2-2.13
  • dejavu >= 2.9-0.10
  • desktop-data-NLD >= 10.1-31.24
  • mozilla-nss >= 3.11.4-0.7
  • mozilla-nss-devel >= 3.11.4-0.7
  • mozilla-nss-x86 >= 3.11.4-0.7
  • openmotif >= 2.2.4-21.12
  • openmotif-demo >= 2.2.4-21.12
  • openmotif-devel >= 2.2.4-21.12
  • openmotif-libs >= 2.2.4-21.12
  • openmotif-libs-x86 >= 2.2.4-21.12
  • sax2 >= 7.1-125.37
  • sax2-gui >= 1.7-125.37
  • sax2-ident >= 1.7-125.38
  • sax2-libsax >= 7.1-125.37
  • sax2-libsax-devel >= 7.1-125.37
  • sax2-libsax-java >= 7.1-125.37
  • sax2-libsax-perl >= 7.1-125.37
  • sax2-libsax-python >= 7.1-125.37
  • sax2-tools >= 2.7-125.37
  • tightvnc >= 1.2.9-201.12
  • xdg-menu >= 0.2-66.10
  • xorg-x11-driver-video >= 6.9.0-46.40
  • xorg-x11-driver-video-nvidia >= 6.9.0-46.40
  • yast2-control-center >= 2.13.10-0.8
  • yast2-qt >= 2.13.82-0.3
  • yast2-x11 >= 2.13.13-0.4
sles10.ia64
sles10.ppc
sles10.x86-64
sles10.x86
sles10.s390x
ZYPP Patch Nr: 2777
SUSE Linux Enterprise Server 10 SP1 for IBM POWER
  • MozillaFirefox >= 2.0.0.2-2.13
  • MozillaFirefox-translations >= 2.0.0.2-2.13
  • dejavu >= 2.9-0.10
  • desktop-data-NLD >= 10.1-31.24
  • mozilla-nss >= 3.11.4-0.7
  • mozilla-nss-64bit >= 3.11.4-0.7
  • mozilla-nss-devel >= 3.11.4-0.7
  • openmotif >= 2.2.4-21.12
  • openmotif-demo >= 2.2.4-21.12
  • openmotif-devel >= 2.2.4-21.12
  • openmotif-devel-64bit >= 2.2.4-21.12
  • openmotif-libs >= 2.2.4-21.12
  • openmotif-libs-64bit >= 2.2.4-21.12
  • sax2 >= 7.1-125.37
  • sax2-gui >= 1.7-125.37
  • sax2-ident >= 1.7-125.38
  • sax2-libsax >= 7.1-125.37
  • sax2-libsax-devel >= 7.1-125.37
  • sax2-libsax-java >= 7.1-125.37
  • sax2-libsax-perl >= 7.1-125.37
  • sax2-libsax-python >= 7.1-125.37
  • sax2-tools >= 2.7-125.37
  • tightvnc >= 1.2.9-201.12
  • xdg-menu >= 0.2-66.10
  • xorg-x11-driver-video >= 6.9.0-46.40
  • xorg-x11-driver-video-nvidia >= 6.9.0-46.40
  • yast2-control-center >= 2.13.10-0.8
  • yast2-qt >= 2.13.82-0.3
  • yast2-x11 >= 2.13.13-0.4
sles10.ia64
sles10.ppc
sles10.x86-64
sles10.x86
sles10.s390x
ZYPP Patch Nr: 2777
SUSE Linux Enterprise Server 10 SP1 for IBM zSeries 64bit
  • MozillaFirefox >= 2.0.0.2-2.13
  • MozillaFirefox-translations >= 2.0.0.2-2.13
  • dejavu >= 2.9-0.10
  • desktop-data-NLD >= 10.1-31.24
  • mozilla-nss >= 3.11.4-0.7
  • mozilla-nss-32bit >= 3.11.4-0.7
  • mozilla-nss-devel >= 3.11.4-0.7
  • openmotif >= 2.2.4-21.12
  • openmotif-demo >= 2.2.4-21.12
  • openmotif-devel >= 2.2.4-21.12
  • openmotif-devel-32bit >= 2.2.4-21.12
  • openmotif-libs >= 2.2.4-21.12
  • openmotif-libs-32bit >= 2.2.4-21.12
  • sax2-tools >= 2.7-125.37
  • tightvnc >= 1.2.9-201.12
  • xdg-menu >= 0.2-66.10
  • yast2-control-center >= 2.13.10-0.8
  • yast2-qt >= 2.13.82-0.3
sles10.ia64
sles10.ppc
sles10.x86-64
sles10.x86
sles10.s390x
ZYPP Patch Nr: 2777
SUSE Linux Enterprise Server 10 SP1 for AMD64 and Intel EM64T
  • MozillaFirefox >= 2.0.0.2-2.13
  • MozillaFirefox-translations >= 2.0.0.2-2.13
  • dejavu >= 2.9-0.10
  • desktop-data-NLD >= 10.1-31.24
  • mozilla-nss >= 3.11.4-0.7
  • mozilla-nss-32bit >= 3.11.4-0.7
  • mozilla-nss-devel >= 3.11.4-0.7
  • openmotif >= 2.2.4-21.12
  • openmotif-demo >= 2.2.4-21.12
  • openmotif-devel >= 2.2.4-21.12
  • openmotif-devel-32bit >= 2.2.4-21.12
  • openmotif-libs >= 2.2.4-21.12
  • openmotif-libs-32bit >= 2.2.4-21.12
  • sax2 >= 7.1-125.37
  • sax2-gui >= 1.7-125.37
  • sax2-ident >= 1.7-125.38
  • sax2-libsax >= 7.1-125.37
  • sax2-libsax-devel >= 7.1-125.37
  • sax2-libsax-java >= 7.1-125.37
  • sax2-libsax-perl >= 7.1-125.37
  • sax2-libsax-python >= 7.1-125.37
  • sax2-tools >= 2.7-125.37
  • tightvnc >= 1.2.9-201.12
  • xdg-menu >= 0.2-66.10
  • xorg-x11-driver-video >= 6.9.0-46.40
  • xorg-x11-driver-video-nvidia >= 6.9.0-46.40
  • yast2-control-center >= 2.13.10-0.8
  • yast2-qt >= 2.13.82-0.3
  • yast2-x11 >= 2.13.13-0.4
sles10.ia64
sles10.ppc
sles10.x86-64
sles10.x86
sles10.s390x
ZYPP Patch Nr: 2777
SUSE LINUX 10.1
  • seamonkey >= 1.0.5-1.1
  • seamonkey-calendar >= 1.0.5-1.1
  • seamonkey-dom-inspector >= 1.0.5-1.1
  • seamonkey-irc >= 1.0.5-1.1
  • seamonkey-mail >= 1.0.5-1.1
  • seamonkey-spellchecker >= 1.0.5-1.1
  • seamonkey-venkman >= 1.0.5-1.1